[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#45198: apt: No handling of dpkg-source unpack failures

Package: apt
Version: 0.3.11
Severity: normal

I tried to unpack a source archive and due to an unrelated bug in dpkg-source
it failed. Now that I've worked around the dpkg-source bug how to I recover? If
I ask apt to install the package it thinks it's already unpacked. Do I have to
delete the directory and redownload it to get apt to do anything here?

dpkg-source: failure: patch gave error exit status 1
Unpack command 'dpkg-source -x ctwm_3.5-10.dsc' failed.
E: Child process failed
# apt-get source ctwm
Reading Package Lists... Done
Building Dependency Tree... Done
Need to get 615kB of source archives.
Get:1 http://debian.midco.net unstable/main ctwm 3.5-10 (dsc) [607B]
Get:2 http://debian.midco.net unstable/main ctwm 3.5-10 (tar) [594kB]
Get:3 http://debian.midco.net unstable/main ctwm 3.5-10 (diff) [20.6kB]
Fetched 3B in 0s (3B/s)
Skipping unpack of already unpacked source in ctwm-3.5

-- System Information
Debian Release: 2.1
Kernel Version: Linux x2-513.mtl.Generation.NET 2.0.36 #2 Sun Jan 17 19:38:45 EST 1999 i686 unknown

Versions of the packages apt depends on:
hi  libc6           2.1.2-0pre12   GNU C Library: Shared libraries and timezone
hi  libstdc++2.9-gl 2.91.66-2      The GNU stdc++ library (EGCS version)

Reply to: