[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#45198: marked as done (apt: No handling of dpkg-source unpack failures)



Your message dated Wed, 15 Sep 1999 21:55:03 -0600 (MDT)
with message-id <Pine.LNX.3.96.990915215409.3403U-100000@Wakko.deltatee.com>
and subject line Bug#45198: apt: No handling of dpkg-source unpack failures
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Darren Benham
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 16 Sep 1999 02:59:10 +0000
Received: (qmail 16779 invoked from network); 16 Sep 1999 02:59:04 -0000
Received: from sparkle.generation.net (205.205.119.4)
  by master.debian.org with SMTP; 16 Sep 1999 02:59:04 -0000
Received: from x2-513.mtl.Generation.NET (brnstndkramden.acf.nyu.edu@x2-513.mtl.Generation.NET [209.205.11.168])
	by sparkle.Generation.NET (8.9.3/8.9.3) with ESMTP id WAA04385;
	Wed, 15 Sep 1999 22:59:07 -0400 (EDT)
Received: from stark by x2-513.mtl.Generation.NET with local (Exim 2.05 #1 (Debian))
	id 11RRl2-0003FD-00; Wed, 15 Sep 1999 22:58:48 -0400
From: gsstark@mit.edu
Subject: apt: No handling of dpkg-source unpack failures
To: submit@bugs.debian.org
X-Mailer: bug 3.2.2
Message-Id: <E11RRl2-0003FD-00@x2-513.mtl.Generation.NET>
Sender: Greg Stark <stark@generation.net>
Date: Wed, 15 Sep 1999 22:58:48 -0400

Package: apt
Version: 0.3.11
Severity: normal

I tried to unpack a source archive and due to an unrelated bug in dpkg-source
it failed. Now that I've worked around the dpkg-source bug how to I recover? If
I ask apt to install the package it thinks it's already unpacked. Do I have to
delete the directory and redownload it to get apt to do anything here?

dpkg-source: failure: patch gave error exit status 1
Unpack command 'dpkg-source -x ctwm_3.5-10.dsc' failed.
E: Child process failed
# POSIXLY_CORRECT=
# unset POSIXLY_CORRECT
# apt-get source ctwm
Reading Package Lists... Done
Building Dependency Tree... Done
Need to get 615kB of source archives.
Get:1 http://debian.midco.net unstable/main ctwm 3.5-10 (dsc) [607B]
Get:2 http://debian.midco.net unstable/main ctwm 3.5-10 (tar) [594kB]
Get:3 http://debian.midco.net unstable/main ctwm 3.5-10 (diff) [20.6kB]
Fetched 3B in 0s (3B/s)
Skipping unpack of already unpacked source in ctwm-3.5
#

-- System Information
Debian Release: 2.1
Kernel Version: Linux x2-513.mtl.Generation.NET 2.0.36 #2 Sun Jan 17 19:38:45 EST 1999 i686 unknown

Versions of the packages apt depends on:
hi  libc6           2.1.2-0pre12   GNU C Library: Shared libraries and timezone
hi  libstdc++2.9-gl 2.91.66-2      The GNU stdc++ library (EGCS version)


Reply to: