[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Pkg-xfce-devel] Bug#556428: Bug#556428: exo-utils: Inconsistent behavior with latest Iceweasel

On dim., 2009-11-15 at 18:39 -0600, Carlo Segre wrote:
> Package: exo-utils
> Version: 0.3.105-3
> Severity: normal
> I have noticed inconsistent behavior of exo-open with the newest
> version of 
> iceweasel (3.5.5-1).  In the past the default setting in the
> "Preferred
> Applications" settings manager dialog, "Debian Sensible Browser" would
> open
> iceweasel (if it were the default alternative) with the correct
> starting
> page (URL or local page) and it would open a second window when
> clicked
> again.
> With the newest installation of iceweasel, both these behaviors have
> changed.  Now the opening page is just the index of the user's home
> directory and a second invocation will open a second tab, not another
> window.
> This issue can be fixed somewhat by setting the preferred application
> to
> iceweasel.  This will correctly open the first instance with the
> desired
> start page but the second invocation, while opening a second window,
> will
> display the default page for opening a new tab instead of a new window
> (in
> my case, a blank page).
> I have briefly tried setting epiphany as my alternative for
> x-www-browser
> and this has the expected behavior, every invocation opens a new
> window with
> the desired start page.  Therefore, this is an interaction with the
> newest
> version of iceweasel.  I have filed this bug here because when I run
> iceweasel directly (from the panel button or form the command line) it
> has
> the correct behavior, it is only the exo-open command which gives this
> inconsistent behavior.

Is that sure? Can you trace it? Run: 

exo-open --launch WebBrowser

Maybe using set -x to see the various calls. Do you have a BROWSER
variable defined? The fact that *only* iceweasel has the problem really
looks like a problem in iceweasel.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://lists.alioth.debian.org/pipermail/pkg-xfce-devel/attachments/20091116/a8971ecc/attachment.pgp>

Reply to: