[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Pkg-xfce-devel] Bug#556428: exo-utils: Inconsistent behavior with latest Iceweasel

Package: exo-utils
Version: 0.3.105-3
Severity: normal

I have noticed inconsistent behavior of exo-open with the newest version of 
iceweasel (3.5.5-1).  In the past the default setting in the "Preferred
Applications" settings manager dialog, "Debian Sensible Browser" would open
iceweasel (if it were the default alternative) with the correct starting
page (URL or local page) and it would open a second window when clicked

With the newest installation of iceweasel, both these behaviors have
changed.  Now the opening page is just the index of the user's home
directory and a second invocation will open a second tab, not another

This issue can be fixed somewhat by setting the preferred application to
iceweasel.  This will correctly open the first instance with the desired
start page but the second invocation, while opening a second window, will
display the default page for opening a new tab instead of a new window (in
my case, a blank page).

I have briefly tried setting epiphany as my alternative for x-www-browser
and this has the expected behavior, every invocation opens a new window with
the desired start page.  Therefore, this is an interaction with the newest
version of iceweasel.  I have filed this bug here because when I run
iceweasel directly (from the panel button or form the command line) it has
the correct behavior, it is only the exo-open command which gives this
inconsistent behavior.


Carlo U. Segre -- Professor of Physics
Associate Dean for Graduate Admissions, Graduate College
Illinois Institute of Technology
Voice: 312.567.3498            Fax: 312.567.3494
segre at iit.edu   http://www.iit.edu/~segre   segre at debian.org

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.30-2-686 (SMP w/1 CPU core)
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

Versions of packages exo-utils depends on:
ii  eject           2.1.5+deb1+cvs20081104-7 ejects CDs and operates CD-Changer
ii  libatk1.0-0     1.28.0-1                 The ATK accessibility toolkit
ii  libc6           2.10.1-5                 GNU C Library: Shared libraries
ii  libdbus-1-3     1.2.16-2                 simple interprocess messaging syst
ii  libexo-0.3-0    0.3.105-3                Library with extensions for Xfce
ii  libglib2.0-0    2.22.2-2                 The GLib library of C routines
ii  libgtk2.0-0     2.18.3-1                 The GTK+ graphical user interface 
ii  libhal-storage1 0.5.13-3                 Hardware Abstraction Layer - share
ii  libhal1         0.5.13-3                 Hardware Abstraction Layer - share
ii  libpango1.0-0   1.26.0-1                 Layout and rendering of internatio
ii  libxfce4util4   4.6.1-1                  Utility functions library for Xfce

exo-utils recommends no packages.

exo-utils suggests no packages.

-- no debconf information

Reply to: