[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#613407: libgl1-mesa-dri: mesa 7.10 should depend on libdrm 2.4.23

Package: libgl1-mesa-dri
Version: 7.10-3
Severity: normal

I just installed mesa 7.10 (from unstable) on a testing system, and it seems
that it also needs libdrm 2.4.23, but it only depends on 2.4.21 (which is
what comes with testing).

With 2.4.21, all programs that used OpenGL hung before being able to render
anything at all. With 2.4.23, everything worked as expected. It should also
be noted that mesa 7.10 requires libdrm 2.4.23 to compile successfully, which
I guess is probably related.

This system uses the i965 driver in case it matters, which I guess it does. It
has an Arrandale chipset.

-- System Information:
Debian Release: 6.0
  APT prefers testing
  APT policy: (500, 'testing'), (400, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libgl1-mesa-dri depends on:
ii  libc6                         2.11.2-10  Embedded GNU C Library: Shared lib
ii  libdrm-intel1                 2.4.23-2   Userspace interface to intel-speci
ii  libdrm-radeon1                2.4.23-2   Userspace interface to radeon-spec
ii  libdrm2                       2.4.23-2   Userspace interface to kernel DRM 
ii  libexpat1                     2.0.1-7    XML parsing C library - runtime li
ii  libgcc1                       1:4.4.5-10 GCC support library
ii  libstdc++6                    4.4.5-10   The GNU Standard C++ Library v3
ii  libtalloc2                    2.0.5-1    hierarchical pool based memory all

libgl1-mesa-dri recommends no packages.

Versions of packages libgl1-mesa-dri suggests:
pn  libglide3                     <none>     (no description available)

-- no debconf information

Reply to: