[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#516210: xserver-xorg-video-radeonhd: "unsupported chipset" despite 1650

On Sun, Nov 22, 2009 at 01:45:37PM +0100, Brice Goglin wrote:
>   [14 lines, 64 words, 388 characters]  Top characters: e0rsoidh
> Jeff Abrahamson wrote:
> >   Nov 22 12:13:33 aragorn kernel: [  198.416261] mtrr: no MTRR for e0000000,10000000 found
> >
> >
> > Odd, that address range (e0000000,10000000) seems like it should exist
> >   
> It's saying there's no MTRR for this exact address range, it's not
> saying that the address range doesn't exist.
> You might want to try building a more recent version of the driver.

I tried something like the following (sorry, it's not in my
.bash_history anymore) and the problem mysteriously disappeared:

   sudo apt-get install $(dpkg -l | grep xserver-xorg | egrep -v '^ii'
   | awk '{print $2}')

Having confirmed that X worked at all, I removed /etc/X11/xorg.conf
and let gdm do its thing.  Success.  Thanks much for your help.

The only remaining problem is that I am not able to turn on two-head
support.  Trying from the gnome monitor thingy
(/usr/bin/gnome-display-properties), I'm told "required virtual size
does not fit available size: requested=(3840, 1200), minimum=(320,
200), maximum=(1920, 1920)".  Google suggests this may be related to
KMS support, which seems from what I read to be driver specific.

  - Is this a driver issue?  If not, I'll follow on elsewhere

  - If it is, is there a work-around?



 Jeff Abrahamson  <http://jeff.purple.com/>
 phone: +44 (0)7827 532 428         (From U.S.: 011-44-7827-532-428)
 GPG fingerprint: 1A1A BA95 D082 A558 A276  63C6 16BF 8C4C 0D1D AE4B

 Recent photos: http://images.purple.com/temp.html

Reply to: