[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#520425: marked as done (xserver-xorg: Xorg crashes at startup)

Your message dated Mon, 30 Mar 2009 21:43:09 +0200
with message-id <49D120CD.9040703@ens-lyon.org>
and subject line Re: Bug#520425: solved
has caused the Debian Bug report #520425,
regarding xserver-xorg: Xorg crashes at startup
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

520425: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=520425
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: xserver-xorg
Version: 1:7.3+18
Severity: normal

Hello! I'm experiencing seriuos problems with xorg: it just
crashes at the start up. I've checked these bugs:
but it seems to me that mine is different from them.
I've stable reproducable crash at startup and I've
commented all xkb options in /etc/X11/xorg.conf.

[ 3977.069659] Xorg[14330]: segfault at 21 ip 7ff3dfdb54af sp 7ffff4b66050 error 4 in libgcc_s.so.1[7ff3dfda5000+16000]
[ 4245.173547] Xorg[14923]: segfault at 21 ip 7f9ad30da4af sp 7fffe7e8d370 error 4 in libgcc_s.so.1[7f9ad30ca000+16000]
[ 4270.805553] Xorg[15024]: segfault at 21 ip 7fc17f7624af sp 7fff94512650 error 4 in libgcc_s.so.1[7fc17f752000+16000]

I tried to downgrade libgcc1 (containing libgcc_s.so.1) to 4.3.3-4, but it didn't help.

How can I make a backtrace? What information should be provided?


-- Package-specific info:
Contents of /var/lib/x11/X.roster:

/var/lib/x11/X.md5sum does not exist.

X server symlink status:
lrwxrwxrwx 1 root root 13 ?  1  2007 /etc/X11/X -> /usr/bin/Xorg
-rwxr-xr-x 1 root root 1901168 ? 20 23:14 /usr/bin/Xorg

Contents of /var/lib/x11/xorg.conf.roster:

VGA-compatible devices on PCI bus:
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AS [Radeon 9550]

/etc/X11/xorg.conf does not match checksum in /var/lib/x11/xorg.conf.md5sum.

Xorg X server configuration file status:
-rw-r--r-- 1 root root 3021 ? 19 22:38 /etc/X11/xorg.conf

Contents of /etc/X11/xorg.conf:

# xorg.conf (xorg X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg
#Section "Device"
#	Identifier  "aticonfig-Device[0]"
#	Driver      "fglrx"

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen_0" 0 0
	InputDevice    "Generic Keyboard"
	InputDevice    "Configured Mouse"

Section "Files"

Section "Module"

	#Disable	    "dri"
	#Disable	    "glx"
	Load  "dri"
	Load  "glx"
	Load  "dbe"

Section "InputDevice"
	Identifier  "Generic Keyboard"
	Driver      "kbd"
	Option	    "CoreKeyboard"
#	Option	    "XkbRules" "xorg"
#	Option	    "XkbModel" "pc105"
#	Option	    "XkbLayout" "us,ru"
#	Option	    "XkbVariant" "basic"
#	Option	    "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"

Section "InputDevice"
	Identifier  "Configured Mouse"
	Driver      "mouse"
	Option	    "CorePointer"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "auto"
#	Option	    "Emulate3Buttons" "true"
	Option	    "Buttons" "7"
	Option	    "ZAxisMapping" "4 5"

Section "Monitor"
	Identifier   " "
	HorizSync    28.0 - 64.0
	VertRefresh  43.0 - 60.0
	Option	    "DPMS"

Section "Monitor"
	Identifier  "Monitor_0"
	Option	    "DPMS" "true"

Section "Device"
	Identifier  " "
	Driver      "vesa"
	BusID       "PCI:1:0:0"

Section "Device"

#	Option      "BusType" "PCI"
	#Option	    "ColorTiling" "true"
#	Option	    "PanelOff" "false"
##	Option	    "DynamicClocks" "true"
	Identifier  "xorg-ati"
	Driver      "ati"
	Option	    "AGPMode" "8"
#	Option	    "AGPFastWrite" "true"
	Option	    "AccelMethod" "XAA"
#	Option      "AccelMethod" "XAA"
	Option	    "DMAForXv" "true"
#	Option	    "MergedFB" "true"
	Option	    "EnablePageFlip" "true"
	BusID       "PCI:1:0:0"

Section "Device"
	Identifier  "aticonfig-Device[0]"
	Driver      "fglrx"

Section "Screen"
	Identifier "Default Screen"
	Device     " "
	Monitor    " "
	DefaultDepth     24
	SubSection "Display"
		Modes    "1280x1024" "1024x768" "800x600" "640x480"

Section "Screen"
	Identifier "Screen_0"
#	Device     "xorg-ati"
	Device     "aticonfig-Device[0]"
	Monitor    "Monitor_0"
	DefaultDepth     24
	SubSection "Display"
		Depth     24
		Modes    "1280x1024" "1024x768" "800x600" "640x480"

Section "DRI"
	Mode         0666

Xorg X server log files on system:
-rw-r--r-- 1 root root 52949 ? 13  2008 /var/log/Xorg.3.log
-rw-r--r-- 1 root root 52076 ? 13  2008 /var/log/Xorg.2.log
-rw-r--r-- 1 root root 44972 ? 19 22:39 /var/log/Xorg.1.log
-rw-r--r-- 1 root root  1975 ? 19 22:41 /var/log/Xorg.0.log

Contents of most recent Xorg X server log file

X.Org X Server 1.4.2
Release Date: 11 June 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux Debian (xorg-server 2:1.4.2-11)
Current Operating System: Linux salmin 2.6.26-1-amd64 #1 SMP Sat Jan 10 17:57:00 UTC 2009 x86_64
Build Date: 20 February 2009  04:53:05PM
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Mar 19 22:39:10 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Screen_0" (0)
(**) |   |-->Monitor "Monitor_0"
(**) |   |-->Device "aticonfig-Device[0]"
(**) |-->Input Device "Generic Keyboard"
(**) |-->Input Device "Configured Mouse"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) FontPath set to:
(==) RgbPath set to "/etc/X11/rgb"
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Loader magic: 0x7c31c0
(II) Module ABI versions:
	X.Org ANSI C Emulation: 0.3
	X.Org Video Driver: 2.0
	X.Org XInput driver : 2.0
	X.Org Server Extension : 0.3
	X.Org Font Renderer : 0.5
(II) Loader running on linux
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/xorg/modules//libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
	compiled for 1.4.2, module version = 1.0.0
	ABI class: X.Org Video Driver, version 2.0
(++) using VT number 7

Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.26-1-amd64 (SMP w/1 CPU core)
Locale: LANG=ru_RU.KOI8-R, LC_CTYPE=ru_RU.KOI8-R (charmap=KOI8-R) (ignored: LC_ALL set to ru_RU.KOI8-R)
Shell: /bin/sh linked to /bin/bash

Versions of packages xserver-xorg depends on:
ii  debconf [ 1.5.26                         Debian configuration management sy
ii  fglrx-dri 1:9-2-2                        non-free AMD/ATI r5xx, r6xx, r7xx 
ii  libc6     2.9-5                          GNU C Library: Shared libraries
ii  x11-xkb-u 7.4+2                          X11 XKB utilities
ii  xkb-data  1.5-2                          X Keyboard Extension (XKB) configu
ii  xserver-x 2:1.4.2-11                     Xorg X server - core server
ii  xserver-x 1:2.0.8-1                      X.Org X server -- evdev input driv
ii  xserver-x 1:1.3.1-1                      X.Org X server -- keyboard input d
ii  xserver-x 1:1.3.0-1                      X.Org X server -- mouse input driv
ii  xserver-x 1:0.3.0-1                      X.Org X server -- dummy display dr
ii  xserver-x 1:6.8.1~git20080301.56a1c9f0-3 X.Org X server -- ATI Mach64 displ
ii  xserver-x 1:6.8.1~git20080301.d855d208-3 X.Org X server -- ATI r128 display
ii  xserver-x 1:6.9.0-1+lenny4               X.Org X server -- ATI Radeon displ
ii  xserver-x 1:2.0.0-1                      X.Org X server -- VESA display dri

Versions of packages xserver-xorg recommends:
ii  libgl1-mesa-dri               7.0.3-7    A free implementation of the OpenG
ii  udev                          0.125-7    /dev/ and hotplug management daemo

xserver-xorg suggests no packages.

-- debconf information:
  xserver-xorg/config/monitor/use_sync_ranges: true
* xserver-xorg/autodetect_monitor: true
* xserver-xorg/config/display/default_depth: 24
* xserver-xorg/config/display/modes: 1280x1024, 1024x768, 800x600
* xserver-xorg/config/inputdevice/keyboard/options:
* xserver-xorg/config/device/use_fbdev: false
* xserver-xorg/config/inputdevice/keyboard/variant:
* xserver-xorg/config/inputdevice/keyboard/layout: us
* xserver-xorg/config/inputdevice/mouse/emulate3buttons: true
  xserver-xorg/config/monitor/horiz-sync: 28-64
* xserver-xorg/config/inputdevice/keyboard/model: pc104
  xserver-xorg/config/monitor/selection-method: Advanced
  xserver-xorg/config/monitor/mode-list: 1280x1024 @ 60Hz
  xserver-xorg/config/monitor/screen-size: 17 inches (430 mm)
  xserver-xorg/config/monitor/vert-refresh: 43-60
* xserver-xorg/autodetect_keyboard: false
* xserver-xorg/config/device/identifier: ???????????
* xserver-xorg/config/device/bus_id: PCI:1:0:0
  xserver-xorg/autodetect_video_card: true
* xserver-xorg/config/inputdevice/keyboard/rules: xorg

--- End Message ---
--- Begin Message ---
Alexey Salmin wrote:
> Suddenly upgrading linux image to 2.6.29 solved the problem. I'm quite
> surprised and happy about it but anyway having xorg broken and fixed
> without certain reasons isn't good.

Looks strange to me as well, but closing anyway...


--- End Message ---

Reply to: