[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#521667: libgl1-mesa-dev: please package dri.pc



Package: libgl1-mesa-dev
Version: 7.4~rc1-1
Severity: normal

X.org from mid 2008 (commit d6b8d9eaffaf3f976db330bc35da3d30eb656bac)
checks for DRI support looking for the dri.pc added to Mesa also in mid
2008. However, the Debian packaging scripts for Mesa 7.4 do not install
the dri.pc file generated during the build.

This means that the next release of the xserver-xorg-core will not be
able to build. I'm pretty sure handling it just like the gl.pc file
should be fine.

Below system information might be wrong, because the bug-reporting
machine isn't the machine where this was actually noticed.

-- System Information:
Debian Release: 5.0
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-1-686 (SMP w/1 CPU core)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libgl1-mesa-dev depends on:
ii  libc6-dev                     2.9-6      GNU C Library: Development Librari
ii  libgl1-mesa-glx               7.4~rc1-1  A free implementation of the OpenG
ii  mesa-common-dev               7.4~rc1-1  Developer documentation for Mesa

libgl1-mesa-dev recommends no packages.

libgl1-mesa-dev suggests no packages.

-- no debconf information

-- 
Paul "TBBle" Hampson, Paul.Hampson@Pobox.com

Shorter .sig for a more eco-friendly paperless office.

Attachment: pgp5SfgFgdwSy.pgp
Description: PGP signature


Reply to: