[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#521253: libdrm: libdrm-dev uninstallable on GNU/kFreeBSD (depends on linux specific package)

Package: libdrm
Severity: important
Version: 2.4.5-1
User: glibc-bsd-devel@lists.alioth.debian.org
Usertags: kfreebsd


the current version of libdrm-dev is uninstallable on GNU/kFreeBSD.

It is due to recently added depends on "linux-libc-dev >= 2.6.28",
which is obviously linux specific.

Please could you either

1) depend on linux-libc-dev only on linux architectures,
   it should suffice to use something like
   "linux-libc-dev [linux-any] >= 2.6.28" in debian/control

2) convert depends into conflicts "linux-libc-dev < 2.6.28"
   as linux-libc-dev is build-essential on linux architectures

Thanks in advance


Reply to: