[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#514975: SOLVED? (old xorg.conf the culprit?)

I upgraded two i686 machines to Lenny and had arbitrary changes in capitalization and other weirdness more like #516028 on one machine, a Compaq/HP nx6310 laptop.

In the end I ran

  # Xorg -configure

and replaced xorg.conf

This seems to have done the trick, no more probs so far.

The format for the input device section seems to have changed somewhat, or some option I had set earlier was incompatabile now with xkb-data.

On the other machine I could not even log in except after wild pressing of Caps Lock on and off at first, later (perhaps after some down- and upgrading) not at all: Pressing enter after the username changed the input for the password to CAPITALS with no chance to undo this.

This second machine though has Sun Ray Server Software running, a Sun keyboard is attached through a Sun Ray desktop unit and a PS/2 keyboard to the machine directly in the server room. I made a new xorg.conf with the above command but also had to use a conventional USB keyboard now on the Sun Ray. Perhaps this can be optimized manually so that PS/2 and Sun USB keyboard can work concurrently. At least I can login again and work.

Needless to say that downgrading xkb-data to various versions had not helped, xkb-data-legacy was not helpful either.

Andreas v. Heydwolff

Reply to: