[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#508614: fatal server error: lockup after changing screen resolutions

Package: xserver-xorg

Version: 1.7.3+18

brand new lenny install disk, ran the install, 1) didn't give the option for desktop in tasksel, only 'standard'
system.  meh
2) installed up to date xserver-xorg
3) ran gdm / gnome, got me to the login screen, and as others have been
complaining about it was at the 'default' what, 640x480 resolution or
something low(never got to find out what), went to change the resoultion
in the gnome resolution changer, changed it to something higher...it was
too high and the screen went all wacky.  No problem --i could see the
menu saying 'press this button or screen resolution will be reverted in
14...13...' countdown finished, tried to revert...black screen.  Since
that point I have gotten nothing but black screens.  Went into
xorg.conf...it was 'empty'-- no drivers listed, no screens listed. Tried adding a few, results in :

Error in I830WaitLpRing(), timeout for 2 seconds
pgetbl_ctl: 0x2ffe0001 getbl_err: 0x00000021
ipeir: 0x00000000 iphdr: 0x54f00006
LP ring tail: 0x000102c0 head: 0x000102e4 len: 0x0001f001 start
eir: 0x0000 esr: 0x0010 emr: 0xff7b
instdone: 0xff41 instpm: 0x0000
memmode: 0x00000000 instps: 0x00000431
hwstam: 0xfffe ier: 0x0002 imr: 0x053c iir: 0x00c0
Ring at virtual 0xaf9b0000 head 0x102e4 tail 0x102c0 count 32759
	00010264: 03cc1900
	00010268: 002800d0
	0001026c: 002c00d4
	00010270: 000e0000
	00010274: 00000000
	00010278: 00000010
	0001027c: 00aa4000
	00010280: 54f00006
	00010284: 03cc1900
	00010288: 002800d4
	0001028c: 002c00d8
	00010290: 000e0000
	00010294: 00000000
	00010298: 00000010
	0001029c: 00aa4000
	000102a0: 54f00006
	000102a4: 03cc1900
	000102a8: 002800d8
	000102ac: 002c00dc
	000102b0: 000e0000
	000102b4: 00000000
	000102b8: 00000010
	000102bc: 00aa4000
	000102c0: 00000720
	000102c4: 00001900
	000102c8: 00000720
	000102cc: 00000020
	000102d0: 00000720
	000102d4: 00000000
	000102d8: 00000720
	000102dc: 00004000
	000102e0: 00000720
	000102e4: 00001900
Ring end
space: 28 wanted 32

Fatal server error:

Deleted xorg.conf...same error above now.  dpkg-reconfigure no longer
allows me to choose my driver(intel), not sure where to go next.

lspci shows the correct card; ...
00:02.0 VGA compatible controller: Intel Corporation
82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 81)

* using kernel 2.6.24-1-686 #1 SMP Thu May 8 02:16:39 UTC 2008 i686
* libc6: 2.7-10

Summary: xorg was showing me something, now it's just giving a blank
screen.  This is basically 'not functional' right off the install disk

Reply to: