[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#405639: Bug#406058: failed to load module kbd

On Mon, Jan  8, 2007 at 13:21:54 -0800, Steve Langasek wrote:

> So what should be done with this bug?  Should it be merged with bug #405639?
> Do you think it needs to be treated as RC independently of bug #405639?
> (FWIW, I don't; smooth upgrades from unofficial backports are absolutely not
> RC in my book.)
I've not been able to reproduce a case where having
Depends: xserver-xorg-input-all | xserver-xorg-input,
         xserver-xorg-video-all | xserver-xorg-video-1.0
Recommends: xserver-xorg-input-all, xserver-xorg-video-all
makes things worse than they currently are, so I would tend towards
doing that.  It fixes the issue with tasksel et al., and should ensure
that aptitude tries as hard as possible to install the -all packages on
upgrade and on initial install.
I'd like to have your and/or David's OK before uploading that, though.

I agree that breaking upgrades from backports of from pre-release etch
is probably not RC, but I'm not sure other upgrade cases aren't broken
right now (like upgrading from xfree86 to xorg using etch's aptitude,
although I haven't tested that yet).


Attachment: signature.asc
Description: Digital signature

Reply to: