[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

glu.h error with recent g++


I noticed the following error message in compiling a glut program:

g++-4.2-20061014 -fsyntax-only /usr/include/GL/glu.h
/usr/include/GL/glu.h:259: error: '<anonymous>' has incomplete type
/usr/include/GL/glu.h:259: error: invalid use of 'GLvoid'

I have a debian 3.1 system.
xlibmesa-glu-dev 4.3.0.dfsg.1-14sarge2

My impression is that the bug is not linked with glut. It is not
blocking, I can use g++-4.2 (I compiled it outside of debian tree) for
syntax and debian 3.1 g++ for binaries.

Have a nice new year 2007!


Reply to: