[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#281050: [i810] Memory leak

Package: xserver-common
Version: 4.3.0.dfsg.1-8
Followup-For: Bug #281050


I'm experiencing heavy XFree86 memory leaking as well.  I killed the
process before finding out about this bug report, so I can't provide any
useful info right now.  Over around 100 hours of active usage the
resident part grew to more than 200MB (right now after restarting X it
is a mere 16MB), and the system became really sluggish.

The bug should not be related to a particular desktop environment or
application: I have switched to GNOME a couple of days ago, because I
thought KDE was slow -- but apparently this leak had been the problem
all the time!  It somehow never struck me to check the memory usage of
the X server, until now.

Please fix this bug, it is *extremely* annoying and disappointing to think
that I will have to restart every couple days to have a usable system.

Thanks for your time,
Gintautas Miliauskas

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: i386 (i686)
Kernel: Linux 2.6.8-custom
Locale: LANG=lt_LT.UTF-8, LC_CTYPE=lt_LT.UTF-8 (charmap=UTF-8)

Versions of packages xserver-common depends on:
ii  debconf [debconf-2.0]     1.4.40         Debian configuration management sy
ii  libc6                     2.3.2.ds1-18   GNU C Library: Shared libraries an
ii  xfree86-common            4.3.0.dfsg.1-8 X Window System (XFree86) infrastr

-- debconf information:
* xserver-common/xwrapper/nice_value: -10
* xserver-common/xwrapper/allowed_users: Console Users Only
  xserver-common/xwrapper/actual_allowed_users: console

Reply to: