[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#235241: bug resolved

On Thursday 11 March 2004 05:00 am, you wrote:
 with 4.3.0-2.
> So, just curious and for the record, would you please try if things
> also do work, when you add
> Option	"VBERestore" "1"
> to your device section?
> thanks.
>    - Christian

Dear Christian,

Thanks for the suggestion.

If I put 
Option	"VBERestore" "1"
in the Device section of XF86Config-4, then I find that the keypress
C-A-F1 will still switch to vt1.  HOWEVER, when I use A-F7 to switch 
back, the screen goes blank.

If I put 
Option	"VBERestore" "0"
then everything works totally correctly.  (I assume that "0" is the 

I have an 845G chipset.  I think that VBERestore option was put in to 
help people with 830G chipsets.  According to 
this option was to allow 830G users to optionally back out a fix that 
had to be put in to get correct behaviour for my chipset, the 845G.

After all of this, I think my problem was not the drivers at all.  It 
turns out that 4.3.0 changed the rules for Xmodmap.  The trap keys 
like C-A-F1 that had been implicit, were put explicitly into the 
internal xmodmap.  If you do "xmodmap -pke" as root in a terminal, 
you'll see them in there.  

I was using an old modified Xmodmap to remap my keyboard, a 
Happy-Hacker's model, to make the diamond keys do a Delete-forward.  
But my Xmodmap didn't have the new entries for the trap keys!  So I 
had to make a new Xmodmap starting from a current output of "xmodmap 
-pke".  That solved the problem.

So I don't know which Debian update "solved" my problem, since my 
problem was of my own making and not something about the drivers.
Sorry.  Hope the above data point helps.


Reply to: