[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#236428: liquidwar 5.6.2-1 and build on m68k

On Sun, Mar 07, 2004 at 11:26:15AM +0100, Eduard Bloch wrote:
> tags 236428 important
> thanks
> > I have a problem with liquidwar and motorola 68000 : the build fails
> > <http://buildd.debian.org/fetch.php?&pkg=liquidwar&ver=5.6.2-1&arch=m68k&stamp=1078042740&file=log&as=raw>
> ...
> > It seems to fail because ld doesn't find libXext.so.6, which is normaly provided by xlibs 
> > (build-depend ok). I don't know what I can do. Any idea?
> Looks like a result of #236428, the libxext package is not pulled in by
> dependency.

I do not understand this statement.

Package: libxext-dev
Section: libdevel
Architecture: any
Depends: libxext6 (= ${Source-Version}), x-dev, libc6-dev | libc-dev
Conflicts: xlibs-dev (<< 4.3.0)
Replaces: xlibs-dev (<< 4.3.0)
Description: X Window System miscellaneous extension library development files
 Header files and a static version of the Xext library are provided by this
 See the libxext6 package for further information.

How is a missing dependency that isn't missing an important bug against

> If you plan a new release of liquidwar, you could add the dependency
> directly to the control file.

I would expect that liquidwar needs to:

Build-Depends: libxext-dev | xlibs-dev (<< 4.3.0)

...among any other build-dependencies it has.

Why is this a libxext-dev bug?

G. Branden Robinson                |
Debian GNU/Linux                   |    Yeah, that's what Jesus would do.
branden@debian.org                 |    Jesus would bomb Afghanistan. Yeah.
http://people.debian.org/~branden/ |

Attachment: signature.asc
Description: Digital signature

Reply to: