Bug#233867: xlibs: list of packages that depend on xlib6g
Leonardo Rochael Almeida <firstname.lastname@example.org> wrote
> FWIW, The following packages, present on my system and installable
> from stable, still require xlib6g, and will either have to be
> removed or will stall an xlibs upgrade:
> navigator/communicator (aka moz 4.77) and it's dependencies
> One question though, considering that xlibs 4.3 claim to "Replace:"
> xlib6g, besides conflicting with it, why can't it simply "Provide:"
> xlib6g and end this mess?
It would not help; the dependencies are versioned, ie.
"Depends: xlib6g (>= 3.3.6-4)" instead of "Depends: xlib6g" and a
versioned dependency cannot be satisfied with a provides.
 I have not gone through the whole list, but I think all of them
"See, I told you they'd listen to Reason," [SPOILER] Svfurlr fnlf,
fuhggvat qbja gur juveyvat tha.
Neal Stephenson in "Snow Crash"