[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#233867: xlibs: list of packages that depend on xlib6g

Package: xlibs
Version: 4.2.1-12.1
Severity: normal
Followup-For: Bug #233867

I have a relatively ancient debian installation that I've been
upgrading (I think I started it way back on ham). Right now it's a
testing/unstable hybrid conteplating the jump to XFree 4.3 due to a
xfce4 dependency.

FWIW, The following packages, present on my system and installable
from stable, still require xlib6g, and will either have to be
removed or will stall an xlibs upgrade:

navigator/communicator (aka moz 4.77) and it's dependencies

There were also these relic packages that I have since removed (trying
to remove xlib6g was a nice cleaning up exercise :-):


And finally, these packages, which should be on the previous list but I
just didn't have the heart to remove them:


The packages on the 1st group are pretty much replaceable with
funcionality from other packages (well, the poster of the initial bug
report clearly disagrees on this on the very 1st package of this list :-)
but I just can't remove quake, so I'll be holding out on the XFree 4.3
upgrade for now.

One question though, considering that xlibs 4.3 claim to "Replace:"
xlib6g, besides conflicting with it, why can't it simply "Provide:"
xlib6g and end this mess? This would have the effect of removing a
package called xlib6g from the system, like Branden wants, and everybody
would be happy and able to keep their ancient packages around. Is there
a library incompatibility or some such?

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable')
Architecture: i386 (i586)
Kernel: Linux 2.4.22-1-k6
Locale: LANG=pt_BR, LC_CTYPE=pt_BR (ignored: LC_ALL set to C)

Versions of packages xlibs depends on:
ii  libc6                       2.3.2.ds1-11 GNU C Library: Shared libraries an
ii  libfreetype6                2.1.7-2      FreeType 2 font engine, shared lib
ii  xfree86-common              4.2.1-12.1   X Window System (XFree86) infrastr

-- no debconf information

Reply to: