[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#221205: Weird crap in root window coming from depths of cache

On Tue, 2003-11-18 at 07:35, Juhapekka Tolvanen wrote: 
> On Mon, 17 Nov 2003, +13:27:56 EET (UTC +0200),
> Michel Dänzer <daenzer@debian.org> pressed some keys:
> > On Mon, 2003-11-17 at 09:45, Juhapekka Tolvanen wrote:
> > > I tried this setting in my Xfree86:
> > > Section "Device"
> > >         Identifier      "Matrox Millennium II"
> > >         Driver          "mga"
> > >         ChipSet         "mga2164w"
> > >         VideoRam        16384
> > My bet is that the card doesn't actually have that much video RAM.
> That VideoRam setting is normally on. I did not put that line for the
> sake of debugging. I am helluva sure, that I have 16 megs of RAM in
> video card, because I have bought such memory upgrade card. In addition
> I have read TFM that came with my video card.
> > The
> > driver takes your word for it though, causing weird effects. Don't
> > override it and let the driver do its job.
> I tried that, too. Driver said, it could not find memory because of
> hardware bug so it settled on some really low default value.

Whoops, I didn't know about these oddities of older Matrox cards...

> Do you think my memory upgrade card is b0rken? Or do you think contact
> pins of that memory upgrade card has become oxidized?

No idea, maybe the driver can't deal with it correctly. What happens if
you have it use 8 megs, e.g.?

You may want to bring this up with XFree86.

Earthling Michel Dänzer      |     Debian (powerpc), X and DRI developer
Software libre enthusiast    |   http://svcs.affero.net/rm.php?r=daenzer

Reply to: