[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#218615: xserver-xfree86: Crash in "Return To Castle Wolfenstein" causes mouse pointer to hang.

retitle 218615 xserver-xfree86: [nvidia] crash in "Return To Castle Wolfenstein" causes mouse pointer to hang
tag 218615 + moreinfo

On Sat, Nov 01, 2003 at 05:15:08PM +0100, Friedrich Delgado Friedrichs wrote:
> Package: xserver-xfree86
> Version: 4.2.1-13
> Severity: normal
> As the subject says. The game crashed (in fullscreen mode) and I saw a
> part of my desktop. Afterwards I was able to regain keyboard control
> by pressing ctrl-alt-KP-Divide and ctrl-alt-KP_Multiply and I was able
> to use my desktop with the keyboard.
> Since I use gpm as a repeater, I was able to switch to the console and
> verify that the mouse worked correctly on the console.
> After I restarted RTCW and quit from it, I was able to move the mouse
> again, but the acceleration was deconfigured (the mouse pointer moved
> very slow).

A couple of observations:
1) You're using NVidia's proprietary server driver.  I can't support
   that.  Can you reproduce the problem using a different brand of video
   card, or with the "vesa" or "vga" drivers?
2) It sounds like RTCW had the pointer grabbed when it died.  Most of
   what you saw was probably to be expected, then.

Of course, it's not good that the X client crashed, but that's
proprietary software, too.

So I guess the bug here is that the mouse's acceleration parameters got
messed up?

G. Branden Robinson                |      To stay young requires unceasing
Debian GNU/Linux                   |      cultivation of the ability to
branden@debian.org                 |      unlearn old falsehoods.
http://people.debian.org/~branden/ |      -- Robert Heinlein

Attachment: signature.asc
Description: Digital signature

Reply to: