[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: i810/i815 graphics glitches at 1280x1024, gart problem?

On Thu, Sep 04, 2003 at 07:06:29PM +0200, Michel D?nzer wrote:
> >    (WW) I810(0): xf86AllocateGARTMemory: allocation of 1024 pages failed
> >            (Cannot allocate memory)
> >    (II) I810(0): No physical memory available for 4194304 bytes of DCACHE
> >    (WW) I810(0): xf86BindGARTMemory: binding of gart memory with key 1
> >            at offset 0x4000000 failed (Invalid argument)
> >    (II) I810(0): Allocation of 4096 bytes for HW cursor failed
> These might only cause the DRI to be disabled (you're reserving all AGP
> memory for the framebuffer, have you tried a lower value for the
> VideoRam directive?), I'm not sure the video problem is related.

Yeah I earlier tried `VideoRam 32768' with no obvious effect (though I guess
it probably could allocate some the ancilarly memory correctly).  I don't
care so much about DRI, at least until the standard output is OK... :-)

Grrr, I really wish I could just slap a debugger on the kernel and see _why_
the allocation is failing... hmmm, maybe I can stick some printks in at least.
ACtually that's not a bad idea...

BTW, in case all my efforts fail, anyone got a recommendation for a good but
cheap `low-profile'* AGP video card that works well with xfree86?  :-)  :-(

* I've actually got an old matrox g400 (or whatever) that I know works great
  at 1280x1024, but this machine has no room for it...


Freedom's just another word, for nothing left to lose   --Janis Joplin

Reply to: