[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

xserver-s3 stoped working?

  I have tried debian-user and xfree86 but didn't got a reply. 
Hopefully someone here will be able to help. In addition, maybe others
with the same old card can tell whether it works for them?
  The following is for an old machine that is being used as a desk top.
It used to follow testing rather closely until the break occurred.
However due to the old hardware it must use xserver-s3 from the old 3.3
tree. This is so because as far as I can tell there is no newer server
for this VLB card. I believe the source classifies this bus as part of
the ISA bus and mentions that it will be supported in the distant
future. Am I wrong? Follows /var/log/xdm/log. The exact identification
of the hardware can be seen here.

    XFree86 Version 3.3.6a / X Window System
    (protocol Version 11, revision 0, vendor release 6300)
    Release Date: xx November 2000
    	If the server is older than 6-12 months, or if your card is newer
    	than the above date, look for a newer version before reporting
    	problems.  (see http://www.XFree86.Org/FAQ)
    Operating System: Linux 2.4.13 i686 [ELF] 
    Configured drivers:
      S3: accelerated server for S3 graphics adaptors (Patchlevel 0)
          newmmio, mmio_928, s3_generic
    (using VT number 7)
    XF86Config: /etc/X11/XF86Config
    (**) stands for supplied, (--) stands for probed/default values
    (**) XKB: rules: "xfree86"
    (**) XKB: model: "pc104"
    (**) XKB: layout: "us"
    (**) Mouse: type: Microsoft, device: /dev/ttyS0, baudrate: 1200
    (**) Mouse: buttons: 3
    (**) S3: Graphics device ID: "MiroCRYSTAL 12sd"
    (**) S3: Monitor ID: "MAG DX1495"
    (**) FontPath set to "/usr/lib/X11/fonts/misc,/usr/lib/X11/fonts/100dpi/:unscaled,/usr/lib/X11/fonts/75dpi/:unscaled,/usr/lib/X11/fonts/Type1,/usr/lib/X11/fonts/Speedo,/usr/lib/X11/fonts/100dpi,/usr/lib/X11/fonts/75dpi"
    (--) S3: chipset:   Trio32 rev. 0
    (--) S3: chipset driver: mmio_928
    (**) S3: Option "power_saver"
    (--) S3: card type: 386/486 localbus
    (--) S3: videoram:  2048k
    (--) S3: Ramdac type: s3_trio32
    (--) S3: Ramdac speed: 135 MHz
    (--) S3: Using Trio32/64 programmable clock (MCLK 54.886 MHz)
    (--) S3: Maximum allowed dot-clock: 80.000 MHz
    (**) S3: Mode "800x600": mode clock =  49.500
    (**) S3: Mode "640x480": mode clock =  31.500
    (**) S3: Using 16 bpp.  Color weight: 565
    (**) S3: Virtual resolution set to 1152x900
    (--) S3: Local bus LAW is 0xF3000000
    (--) S3: Using a banksize of 2048k, line width of 1152
    (--) S3: Using a single 9x9 area at (1143,901) for expanding pixmaps
    (--) S3: No font cache available
  I can't see any indication that something is wrong other then the fact
that after
    /etc/init.d/xdm start
the `No font cache available' is the last line in /var/log/xdm.log.
There are hidden X related files in /tmp, there is an appropriate
/var/run/xdm.pid, there is a switch to VT7 and it doesn't get back to
any other VT, yet I can't see the XDM login screen. It looks like the
machine doesn't recognize that something is wrong. Similarly, startx
doesn't gives any indications that I can see that something is wrong but
X doesn't appear on the screen.
  Any suggestions where to get a lead to what is wrong?
  The problem first appeared a few days ago, after I got the latest
update of testing. Suddenly, during the dselect-upgrade, the X screen
disappeared and the screen got blank. Just like now there is a switch
to VT7 but no actual display. I believe now it is something to do with
the software although at the time I was looking for a hardware problem
and didn't record the packages that were upgraded. I have ruled out a
hardware problem due to the fact that the monitor works fine with MS
Windows and with Linux consoles. It worth mention that in the last week
or so before that final breakage, it appeared as if the X server is
gradually loosing control. By that I mean that the machine is usually 
runs for days without a reboot and over time one could have noticed that
the edges of the windows that were close to the screen border gradually
fall off the viewable screen area. Similarly, the fixed fonts that I
use were noticeably narrow at the border of the window that was at the
edge of the screen. Before that the X system worked well for years. I
also believe that 4.2.1-6 hit testing recently.

  As an aside, is there a way to build only some debs and not the whole
X suit? I have tried to use pbuilder on the Debian sources. However the
building process got into a D state, probably due to load on the
machine. When the load was removed it got out of the D state but took 
Gigs of disk space. I had to kill it. I believe both the D state and the
need for tremendous disk space were when using groff or something 
similar to create the docs.


    Shaul Karl, shaulka@bezeqint.n e t

Reply to: