[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#171305: marked as done (xserver-xfree86: package preconfiguration fails with 'ttyS: ... input overruns(s)')



Your message dated Tue, 25 Mar 2003 17:09:29 -0500
with message-id <20030325220929.GB908@deadbeast.net>
and subject line Bug#171305: Followup
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 1 Dec 2002 00:11:30 +0000
>From rparnes@megalink.net Sat Nov 30 18:11:29 2002
Return-path: <rparnes@megalink.net>
Received: from (sam.localdomain) [66.231.193.165] (mail)
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 18IHho-0001IP-00; Sat, 30 Nov 2002 18:11:29 -0600
Received: from bp by sam.localdomain with local (Exim 3.35 #1 (Debian))
	id 18IHjh-00008e-00
	for <submit@bugs.debian.org>; Sat, 30 Nov 2002 19:13:25 -0500
Date: Sat, 30 Nov 2002 19:13:25 -0500
From: Bob Parnes <rparnes@megalink.net>
To: submit@bugs.debian.org
Subject: Xfree86 Package Configuration Failure
Message-ID: <20021201001325.GA506@megalink.net>
Reply-To: rparnes@megalink.net
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/1.3.28i
Sender: Robert Parnes <bp@abe.localdomain>
Delivered-To: submit@bugs.debian.org
X-Spam-Status: No, hits=-7.2 required=5.0
	tests=SIGNATURE_SHORT_DENSE,SPAM_PHRASE_00_01,USER_AGENT,
	      USER_AGENT_MUTT
	version=2.41
X-Spam-Level: 

Package: xserver-xfree86

Version: 4.2.1-3

Installation fails, with an apparently endless series of lines complaining
about input overruns, when I try to upgrade from version 4.1.0. Following
is an example, recorded after I downloaded the .deb packages, from a 
console without X running.

Reading Package Lists...
Building Dependency Tree...
The following extra packages will be installed:
  libc6 libc6-dev libc6-pic libdb1-compat locales 
The following NEW packages will be installed:
  libdb1-compat 
5 packages upgraded, 1 newly installed, 0 to remove and 394  not upgraded.
Need to get 0B/14.0MB of archives. After unpacking 1012kB will be freed.
Do you want to continue? [Y/n] 

Preconfiguring packages ...

ttyS: 1 input overrun(s)
ttyS: 257 input overrun(s)
ttyS: 257 input overrun(s)
ttyS: 257 input overrun(s)
ttyS: 257 input overrun(s)
ttyS: 257 input overrun(s)

etc., continuing until I press ctrl-c. I tried this several times; sometimes
the numbers differ, on two occasions the keyboard froze.

To test whether one of the the extra packages is responsible, I installed
them separately, using dpkg. Then I ran dpkg on the xserver-xfree86
package, and the above overrun(s) lines again appeared.

Kernel version is 2.4.20-pre7-ac3, libc-2.2.5.so is on the system.

Motherboard is an intel 845 with P4 1700 MHZ cpu. /home directory is set up 
with software raid 1. The kernel is the result of two patches applied to 
version 2.4.19, in order to support a Promise ultra 133 TX2 controller. Two 
hard drives: seagate 80 GB 7200 rpm and quantum 15 GB 5400 rpm.

Bob Parnes


-- 
Bob Parnes
rparnes@megalink.net

---------------------------------------
Received: (at 171305-done) by bugs.debian.org; 25 Mar 2003 22:09:30 +0000
>From branden@deadbeast.net Tue Mar 25 16:09:29 2003
Return-path: <branden@deadbeast.net>
Received: from dhcp16621067.indy.rr.com (redwald.deadbeast.net) [24.166.21.67] 
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 18xwbp-0008Hm-00; Tue, 25 Mar 2003 16:09:29 -0600
Received: by redwald.deadbeast.net (Postfix, from userid 1000)
	id 2160E640F6; Tue, 25 Mar 2003 17:09:29 -0500 (EST)
Date: Tue, 25 Mar 2003 17:09:29 -0500
From: Branden Robinson <branden@debian.org>
To: 171305-done@bugs.debian.org
Subject: Re: Bug#171305: Followup
Message-ID: <20030325220929.GB908@deadbeast.net>
References: <20021214164222.GA678@megalink.net> <20030225205848.GH32138@deadbeast.net> <20030302230704.GA2208@megalink.net> <20030303004523.GA10730@deadbeast.net> <20030323184136.GA591@megalink.net>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="4bRzO86E/ozDv8r1"
Content-Disposition: inline
In-Reply-To: <20030323184136.GA591@megalink.net>
User-Agent: Mutt/1.5.3i
Delivered-To: 171305-done@bugs.debian.org
X-Spam-Status: No, hits=-3.7 required=4.0
	tests=IN_REP_TO,PGP_SIGNATURE_2,QUOTED_EMAIL_TEXT,REFERENCES,
	      SPAM_PHRASE_00_01,USER_AGENT,USER_AGENT_MUTT
	version=2.44
X-Spam-Level: 


--4bRzO86E/ozDv8r1
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Sun, Mar 23, 2003 at 01:41:36PM -0500, Bob Parnes wrote:
> On Sun, Mar 02, 2003 at 07:45:23PM -0500, Branden Robinson wrote:
> > Does it work if you remove the read-edid package?
[...]
> Sorry for the long and delayed reply.
>=20
> I have another and older computer, mostly unused. So I tried to
> duplicate the setup on that. I installed the Promise controller and a
> second hard drive. Using the root filesystem on the main drive, I set=20
> up a new partition  and transferred a base filesystem created from=20
> debootstrap. I booted to it, set up raid1, installed read-edid, installed
> xfree86 4.1 and got X working. I then upgraded to xfree86 version 4.2,=20
> and the upgrade went smoothly, with no errors.
>=20
> So I moved the controller and hard drive back to the original computer.
> However, the computer did not boot. It hung after detecting the ttyS00=20
> and ttyS01 ports. Normally it also detects ttyS04, but it hung. The=20
> keyboard did not work, the power switch did not function, but the reset
> button did.
>=20
> I turned off the computer and disconnected the hard drive from the
> Promise controller. This time the boot continued to the point where the
> system detected lp0. Then the screen began to show the same error
> messages that caused me to file a bug report, i.e.:
>=20
> ttyS: 1 input overrun(s)
> ttyS: 257 input overrun(s)
>=20
> At this point I did a ctrl-C interrupt, and the boot process continued,
> apparently successfully, and I was able to run X.
>=20
> I then removed the read-edid package, and rebooted, but the result was
> the same: the same error messages appeared, but after a ctrl-C
> interrupt, the boot was successful.
>=20
> This was not exactly the same behavior I experienced originally. In one
> last trial, I moved the controller to a different pci slot, but the result
> was the same. Without the controller, everything works fine.=20
>=20
> There is one other possibility which I did not evaluate: I had not bother=
ed
> to uninstall the raid package, which is still running without a second
> drive. I believe it was running in my original experiences with this
> problem, but I am willing to try again if it would be helpful. One last
> possibility is that the secondary hard drive is different: it was
> originally an older 15GB Quantum, and for these tests I used an 80GB
> Maxtor; that may account for the refusal to boot at all with the hard
> drive connected.
>=20
> So my experience with two computers is that the problem, in whatever
> form,  occurs with this controller mounted on an intel 845BG motherboard;=
=20

The graphics subsystem of the Intel 845G chipset is not supported by any
version of XFree86 prior to 4.3.0, which is not yet officially packaged
for Debian.

> it does not occur with an older motherboard, which I believe is a via 693=
ATX.
> The presence of read-edid has no effect.
>=20
> If this information is too obscure to make sense, I won't feel hurt if
> you decide to dismiss the bug report.

The other problems you described, about the power button not working,
etc., I do not think have anything to do with XFree86.

There is already a bug on file with the Debian BTS about 845G support,
therefore I am closing this bug.

If you disagree with this decision please let me know.

--=20
G. Branden Robinson                |    To Republicans, limited government
Debian GNU/Linux                   |    means not assisting people they
branden@debian.org                 |    would sooner see shoveled into mass
http://people.debian.org/~branden/ |    graves.          -- Kenneth R. Kahn

--4bRzO86E/ozDv8r1
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.1 (GNU/Linux)

iEYEARECAAYFAj6A05gACgkQ6kxmHytGonwS+wCeL6ZoljvqM2sk+bjx81ECx4Wz
jBoAnjH/TWzAzKtU4GdqH5smwfa/j+Mc
=hMbN
-----END PGP SIGNATURE-----

--4bRzO86E/ozDv8r1--



Reply to: