[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#171305: Followup

On Sun, Mar 02, 2003 at 07:45:23PM -0500, Branden Robinson wrote:
> On Sun, Mar 02, 2003 at 06:07:04PM -0500, Bob Parnes wrote:
> > > Please mail this bug the output of the following command:
> > > 
> > > dpkg -l mdetect read-edid
> > > 
> > > -- 
> > > G. Branden Robinson                |    I'm sorry if the following sounds
> > > Debian GNU/Linux                   |    combative and excessively personal,
> > > branden@debian.org                 |    but that's my general style.
> > > http://people.debian.org/~branden/ |    -- Ian Jackson
> > 
> > Here it is
> > ---------------------------------------------------------------------------------
> > 
> > Desired=Unknown/Install/Remove/Purge/Hold
> > | Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
> > |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
> > ||/ Name           Version        Description
> > +++-==============-==============-============================================
> > un  mdetect        <none>         (no description available)
> > ii  read-edid      1.4.1-2        hardware information-gathering tool for VESA
> Does it work if you remove the read-edid package?
> E.g.:
> # apt-get --remove read-edid
> -- 
> G. Branden Robinson                |
> Debian GNU/Linux                   |      Ignorantia judicis est calamitas
> branden@debian.org                 |      innocentis.
> http://people.debian.org/~branden/ |

Sorry for the long and delayed reply.

I have another and older computer, mostly unused. So I tried to
duplicate the setup on that. I installed the Promise controller and a
second hard drive. Using the root filesystem on the main drive, I set 
up a new partition  and transferred a base filesystem created from 
debootstrap. I booted to it, set up raid1, installed read-edid, installed
xfree86 4.1 and got X working. I then upgraded to xfree86 version 4.2, 
and the upgrade went smoothly, with no errors.

So I moved the controller and hard drive back to the original computer.
However, the computer did not boot. It hung after detecting the ttyS00 
and ttyS01 ports. Normally it also detects ttyS04, but it hung. The 
keyboard did not work, the power switch did not function, but the reset
button did.

I turned off the computer and disconnected the hard drive from the
Promise controller. This time the boot continued to the point where the
system detected lp0. Then the screen began to show the same error
messages that caused me to file a bug report, i.e.:

ttyS: 1 input overrun(s)
ttyS: 257 input overrun(s)

At this point I did a ctrl-C interrupt, and the boot process continued,
apparently successfully, and I was able to run X.

I then removed the read-edid package, and rebooted, but the result was
the same: the same error messages appeared, but after a ctrl-C
interrupt, the boot was successful.

This was not exactly the same behavior I experienced originally. In one
last trial, I moved the controller to a different pci slot, but the result
was the same. Without the controller, everything works fine. 

There is one other possibility which I did not evaluate: I had not bothered
to uninstall the raid package, which is still running without a second
drive. I believe it was running in my original experiences with this
problem, but I am willing to try again if it would be helpful. One last
possibility is that the secondary hard drive is different: it was
originally an older 15GB Quantum, and for these tests I used an 80GB
Maxtor; that may account for the refusal to boot at all with the hard
drive connected.

So my experience with two computers is that the problem, in whatever
form,  occurs with this controller mounted on an intel 845BG motherboard; 
it does not occur with an older motherboard, which I believe is a via 693ATX.
The presence of read-edid has no effect.

If this information is too obscure to make sense, I won't feel hurt if
you decide to dismiss the bug report.

Bob Parnes

Reply to: