[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Ralf's X backport compiled with the wrong g++

Hash: SHA1

On Friday 21 March 2003 08:52, you wrote:
> Hi Ralf,
> the g++ libraries from your backport of the experimental packages of
> XFree86 4.3.0 you announed at [1] are compiled with g++ 2.95 although
> they must be compiled with g++ 3.2.

Hi Adrian,

well, considering that woody's default compiler is gcc 2.95 I don't see a
reason to compile it with gcc-3.2. That would basically mean that I would
need to do a woody transition to gcc-3.2 completely and there's no way I'm
going to do that :-)

> Much worse is that this will cause breakages if people use these broken
> packages together with packages from sarge/unstable or if they use other
> packages you backported together with correct future XFree86 4.3.0
> packages from sarge/unstable.

I'm building woody only and woody is - as you surely know - relying on 2.95 as
its compiler.

If people are mixing their woody installations with stuff from testing and
unstable they clearly have to know what they're doing - because they'll run
into such problems.

Either stick with woody (my repositories are large enough to fulfill the
current desktop user's needs and you can get OO and Mozilla elsewhere) or go
with testing and unstable.

> Please fix your backport packages.
> Adrian
> [1] http://lists.debian.org/debian-kde/2003/debian-kde-200303/msg00459.html

- --
We're not a company, we just produce better code at less costs.
- --------------------------------------------------------------------
Ralf Nolden

The K Desktop Environment       The KDevelop Project
http://www.kde.org              http://www.kdevelop.org
Version: GnuPG v1.2.1 (GNU/Linux)


Reply to: