[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#169427: xserver-xfree86: Applies for "autodetecting" USB/PS2 mouse setup too, but only on boot

Package: xserver-xfree86
Version: 4.2.1-3
Followup-For: Bug #169427


Monday I got a logitech optical USB/PS2 mouse, and used it on PS2.
Just to try out USB in linux I set it up on USB afterwards, and changed
my XF86Config-4 to try to use both devices (psaux and input/mice), X11
would just take the one(s) that are present. This worked perfectly when
testing by ^-M-<backspace> -ing wdm after editing the config, but
thuesday morning, I couldn't type anything anymore in wdm, changing
console and killing X didn't work either, sysrq to the resque.

Note that it worked when disabling wdm's init script, booting, logging
in as root and starting the init script then. This really puzzles me,
since it indicates that this can't have anything to do with

I knew of this issue, since tpo hangs in the same IRC channel as /me,
and thus tried with AllowMouseOpenFail enabled and really, now the
keyboard worked.

Maybe this provides some nice test case.

-- Package-specific info:
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G200 AGP (rev 01)
01:00.0 Class 0300: 102b:0521 (rev 01)

# XF86Config-4 (XFree86 server configuration file) generated by dexconf, the
# Debian X Configuration tool, using values from the debconf database.
# Edit this file with caution, and see the XF86Config manual page.
# (Type "man XF86Config" at the shell prompt.)
# If you want your changes to this file preserved by dexconf, only make changes
# before the "### BEGIN DEBCONF SECTION" line above, and/or after the
# "### END DEBCONF SECTION" line below.

Section "Files"
#	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/TrueType"
	FontPath	"/usr/lib/X11/fonts/Speedo"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"

Section "Module"
	Load	"GLcore"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"pex5"
	Load	"speedo"
	Load	"type1"
	Load	"vbe"
	Load	"xie"

Section "InputDevice"
	Identifier	"Keyboard"
	Driver		"keyboard"
	Option		"XkbRules"	"xfree86"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"de_CH"

Section "InputDevice"
	Identifier	"USB Mouse"
	Driver		"mouse"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"IMPS/2"
	Option		"Buttons"		"5"
	Option		"ZAxisMapping"		"4 5"
	Option		"SendCoreEvents"	"yes"

Section "InputDevice"
	Identifier	"PS2 Mouse"
	Driver		"mouse"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"IMPS/2"
	Option		"Buttons"		"5"
	Option		"ZAxisMapping"		"4 5"
	Option		"SendCoreEvents"	"yes"

Section "Device"
	Identifier	"MGA G200"
	Driver		"mga"
	Option		"UseFBDev"		"no"

Section "Monitor"
	Identifier	"Philips 107MB"
	HorizSync	30-86
	VertRefresh	50-160
	Option		"DPMS"
	Gamma		1.1

Section "Screen"
	Identifier	"Default Screen"
	Device		"MGA G200"
	Monitor		"Philips 107MB"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
	SubSection "Display"
		Depth		4
		Modes		"1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		16
		Modes		"1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"PS2 Mouse"	"CorePointer"
	InputDevice	"USB Mouse"
	InputDevice	"Keyboard"	"CoreKeyboard"

Section "DRI"
	Mode	0666

Section "ServerFlags"
	Option		"AllowMouseOpenFail"		"yes"

[ Deleted the log, since it's not fundamentally different from what tpo
sent you. ]

-rw-r--r--    1 root     root        25350 2002-11-20 18:06 /var/log/XFree86.0.log
-rw-r--r--    1 root     root        21513 2002-11-12 15:42 /var/log/XFree86.1.log

-- System Information:
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux turing 2.4.19 #1 Sam Nov 16 16:47:16 CET 2002 i586
Locale: LANG=de_CH, LC_CTYPE=de_CH

Versions of packages xserver-xfree86 depends on:
ii  debconf                       1.2.16     Debian configuration management sy
ii  libc6                         2.3.1-5    GNU C Library: Shared libraries an
ii  xserver-common                4.2.1-3    files and utilities common to all 
ii  zlib1g                        1:1.1.4-7  compression library - runtime

-- debconf information excluded

Reply to: