[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with xfree86 4.0.1d - Compac Armada 1500c (CT69000+DSTN)

Taketoshi Sano <sano@debian.org> writes:
> 4.0.1e has some updates on C&T driver, it does not use cfb now but uses fb.
> But I'm not sure if this new version can solve this problem, the change 
> from 4.0.1d to 4.0.1e may be just irrelevant.

4.0.1e, as packaged in 4.0.1-2, works for me!  It's a good thing, as
48 hours without X was almost more than I could take.  :-)

One interesting thing is that it seems I really do have a C&T69000,
even though my documentation says I have a 65555 and that is also what
worked with X 3.x.x.  If I put Chipset "ct65555" in my XF86Config now,
then nothing crashes, but the display is horribly screwed up.  But if
I let the driver autodetect the chip, it decides it is a ct69000 and
all is well.  (But this is a completely separate issue from the crashes
I was having before, as I tried both ways, and lots of other stuff,
with 4.0.1d.)

A few quirks remain:

- When I switch to a virtual console, it is quite dim.  This goes away
  if I suspend and resume my machine, but it didn't happen before.
  Any idea what's going on?

- My xterms show up with black backgrounds and white text.  Putting
  XTerm*reverseVideo: true (or false) in my .Xresources and -merging it
  doesn't help (although it did cause the reverseVideo menu entry to
  get ticked).  But if I -load my .Xresources, then I get reverse
  video.  It seems like the foreground and background settings from
  app-defaults/XTerm-color are being applied after foreground and
  background are switched.

- Icons in my fvwm button-bar which are supposed to have transparent
  backgrounds are showing up with black backgrounds.

- My xdm.log contains:
    xdm error (pid 11747): SetPerClientControls failed
    rm: cannot remove `/var/run/xconsole.pid': No such file or directory
  Any idea what this is?

- What's a good way to test the speed of the X server?  This is just
  out of curiosity.

Thanks for all the help people provided while I was trying to get
this working!  And thanks to Branden for putting it all together!


Reply to: