[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X suddenly exits. Segv???

At 03:14 AM 9/22/00 -0700, Karl M. Hegbloom wrote:
Package: xserver-xfree86
Version: 4.0.1-0phase2v7

 Twice I've had X suddenly exit on me.  Both times, iirc, it was when
 I pushed the "X" button to close a Mozilla frame via the WM.  I don't
 know if it's a segv or what; it just suddenly snicks out, then `gdm'
 restarts.  Once it was this version, another time before it was the
 previous (?) phase 2 binary.

 Has this happened to anyone else?

I think that has happened to me once, but three or four times I have waken up to find that my X session has reset in the middle of the night (I tend to stay logged in for days/weeks at a time).

The last two times that has happened coincided with network outages (cable modem reset the first time, router[1] turned off and disassembled last night)

This morning, I woke up to find that Enlightenment now believes that my X server no longer has XSHM support. I don't know which version of the X packages I'm running, I upgraded last night. Also, it seems like DPMS works with xdm, but not with Enlightenment. I'm using the stock Matrox G400 driver.

Any ideas with these issues?

[1] our router is an old PowerMac, used because it was the spare computer in the house -- and therefore less expensive than building a dedicated Debian box. As it is, for 5 machines, we have 4 networks, 4+ operating systems, 4 dedicated hubs/bridges/translators, etc.

Reply to: