[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

no libGLU in xlibgl1 and no dri module for tdfx

I have a Voodoo3 graphics card and was trying out direct rendering, which
worked with the 4.0.1 that I compiled myself. I installed the experimental
4.0.1 packages (phase1v6), and after figuring out the error with the X
wrapper (the XF86_NONE problem), I got the server working. However, I
stumbled upon two issues, one is libGLU is missing from xlibgl1, and the
other is no support for tdfx_dri was compiled in.

First, xlibgl1 which is supposed to replace Mesa. However, only libGL is
provided by xlibgl1. Either xlibgl1 should include libGLU or the Mesa
packages need to split off libGLU into a separate package.

Secondly, no dri tdfx support is included in the packages. The tdfx
support depends on glide3 libraries compiled with DRI support.

I also tried to get dri support to work by copying the tdfx_dri.so and
libglide3 from the 4.0.1 I had compiled previously. Direct rendering
worked, but caused the X server to segfault randomly. This is the only
error message reported, from the kernel after X dies:
[drm:drm_release] *ERROR* Process 10842 dead, freeing lock for context 1

I would like to compile the X packages myself to add tdfx support in the
meantime. Please let me know what I need to properly build the X packages,
and where to find anything not already in debian/unstable

Reply to: