[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

mp4h seems to misparse the ê character as <

Package: mp4h

On Sat, Aug 19, 2000 at 10:35:44PM +0200, peter karlsson wrote:
> I upgraded to the wml in woody (2.0.2), since the CVS files no longer
> work with the potato wml, and now I can't get it to work:
> $ make
> wml -q -D CUR_YEAR=2000 -o UNDEFuEN:HOWTO_start_list.en.html@g+w HOWTO_start_list.wml
> /usr/lib/wml/exec/wml_p2_mp4h: ERROR:/home/peter/tmp/wml.9534.tmp2.wml:499: EOF when reading argument of the `pne' tag
> ** WML:Break: Error in Pass 2 (rc=1).
> make: *** [HOWTO_start_list.en.html] Error 1
> I can't see what's wrong with the file, so would anyone with a little
> more insight into wml's innermost secrets tell me what is wrong here?

This is the second problem of the sort. I think it barfed at this line:

        [PL:debian, GNU, linux, unix, wolnodostêpne ¼ród³a, darmowy, DFSG:]
The underlined sequence apparently makes mp4h die, it seems to interpret the
Latin2 letter ê (that's `e' with a cedilla, or what's the name) as <, i.e.
the start of a tag.

The second case:

make[4]: Entering directory `/debian2/web/webwml/japanese/SPI/corporate/resolutions'
wml -q -o UNDEFuJA:index.ja.html.tmp --prolog="/usr/bin/kcc -e -" --epilog="../../convert index.ja.html" index.wml
/usr/lib/wml/exec/wml_p2_mp4h: ERROR:/tmp/wml.10869.tmp2.wml:0: EOF when reading argument of the `zyk' tag
** WML:Break: Error in Pass 2 (rc=1).
make[4]: *** [index.ja.html] Error 1
make[4]: Leaving directory `/debian2/web/webwml/japanese/SPI/corporate/resolutions'

It gets strange. If you run
  wml ~treacy/break.wml
you get the correct output. But if you copy the file to the directory above,
it fails with the same message.

After creating a .wmlrc in that directory, which shouldn't be necessary,
it then compiles fine as does index.wml.

(these notes were written by Jay Treacy who investigated it, but is away
right now)

And it also seems to be caused by the same thing:

[joy@pork:~/cvs/webwml/english/template/debian]% grep zyk * 2>/dev/null
languages.wml:  [PL:Ta strona jest równie¿ dostêpna w nastêpuj±cych jêzykach:]
languages.wml:  [PL:Jak ustawiæ domy¶lny jêzyk dokumentu:]
menubar.wml:    [PL:Ró¿ne&nbsp;jêzyki&nbsp;w&nbsp;Debianie:]

Funny, I just tried building that file at home, and it worked. There was no
.wmlrc in the directory.

Digital Electronic Being Intended for Assassination and Nullification

Reply to: