[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Build failure because python3 isn't found

You don't have a build-depends on python3, so where is your surprise?..

It seems to me that a makefile from that package is using python3 directly.   Probably something else before was pulling it in (same in your chroot...) And now it isn't anymore.  That's a RC bug waiting to be filed.

On Sat, 19 Sep 2020, 8:33 pm Julien Puydt, <julien.puydt@gmail.com> wrote:

I was surprised to see my recent upload of giac fail on most

It turned out that the common issue was:
   python3: No such file or directory

This is especially strange since :

- I use a schroot build to check for missing b-deps (but perhaps my
schroot isn't that clean?) : worked.

- I since tried to build my package in schroot on two porterbox
machines (barriere for amd64 and abel for armhf) : worked.

So I'm wondering if for some reason my package was built at a crucial
moment when something was amiss (in which case re-triggering the build
will solve the issue) or if there's really something fishy I should
investigate and solve?



Reply to: