[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

issues upgrading wanna-build and it's web interface for buildd.raspbian.org .

(note: I sent an earlier version of this mail to buildd-tools-devel but didn't get any replies there, pabs suggested this list may be a better bet)

I recently tried to upgrade the wanna-build web interface for buildd.raspbian.org to the latest version but i'm getting.

: include(/srv/buildd.debian.org/etc/binsrc_assoc.php): failed to open stream: No such file or directory in /srv/buildd.debian.org/www/status/library.php on line 29

Warning: include(): Failed opening '/srv/buildd.debian.org/etc/binsrc_assoc.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /srv/buildd.debian.org/www/status/library.php on line 29

Warning: pg_query(): Query failed: ERROR: column "vancouvered" does not exist LINE 1: SELECT distribution, architecture, vancouvered ^ in /srv/buildd.debian.org/www/status/library.php on line 115

Warning: pg_fetch_assoc() expects parameter 1 to be resource, boolean given in /srv/buildd.debian.org/www/status/library.php on line 116

Warning: pg_free_result() expects parameter 1 to be resource, boolean given in /srv/buildd.debian.org/www/status/library.php on line 121

Notice: Use of undefined constant BUILDD_SCHEME - assumed 'BUILDD_SCHEME' in /srv/buildd.debian.org/www/status/library.php on line 1588

>From looking at
buildd.debian.org it seems /srv/buildd.debian.org/etc/binsrc_assoc.php is a generated file but i'm not sure what is supposed to generate it. As a temporary measure I grabbed the file from the debian wanna-build server but i'd really like to know how it's generated so I can have a version that is updated frequently and that is correct for my distribution.

I have failed to find any details or explanation of the "vancouvered" column with my google searches and it does not seem to be in the schema files I got from https://buildd.debian.org/git/wanna-build.git/ . As a temporary measure I hacked the code to not read that field but i'd still like to know what the proper soloution is.

The next two errors seem to be cascades from the first two.

The final error seems to have been a newly introduced constant that needed to be set to a URL scheme (http or https) to use in generating urls.

Another issue I ran into was the old ssh wrapper was gone preventing any of my buildds talking to the main server. It took some fiddling to find out how to make the new one work, for reference it's

command="/srv/wanna-build/bin/wanna-build --ssh-wrapper <hostname>" ssh-rsa <key> <comment> buildd@debian-armhf

It seems the "hostname" has to match an entry in /srv/wanna-build/etc/buildd/buildd.yaml , it doesn't seem to matter if it actually matches the name of the individual buildd (so it seems to still be fine to have all buildds use the same key).

Any help would be greatly appreciated.

Reply to: