[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: installing debian 10 without a cd and without usb but could use ethernet

Dan Hitt wrote: 
> On Thu, Jan 21, 2021 at 10:02 AM Dan Ritter <dsr@randomstring.org> wrote:
> > > also have to be a search line like David has (search --no-floppy ......)
> > to
> > > identify just where '/boot' is (???).
> >
> >
> > https://en.wikipedia.org/wiki/GNU_GRUB#Startup_on_systems_using_BIOS_firmware
> >
> > stage 2: core.img loads /boot/grub/i386-pc/normal.mod from the
> > partition configured by grub-install. If the partition index has
> > changed, GRUB will be unable to find the normal.mod, and
> > presents the user with the GRUB Rescue prompt.
> >
> > So the answer to your question is, it's been configured at
> > install time, not discovered at runtime.
> >
> > -dsr-
> >
> Thanks Dan for your mail, and for the reference to the wikipedia article.
> When you say 'configured at install time', does that refer to the time at
> which i run 'sudo update-grub' (on my mint host)?

That's a possible install time. Another possible install time is
when the creator of an ISO image - say, the netinst.iso - runs
update-grub on the bootloader for that image. (Somebody with
more expertise in CD booting might be able to say more.)

Consider that your computer decides which disk to read the boot
sector from, and after that it's all up to what that boot sector

> (I presume that it is impossible that this refers to the time when grub
> itself was last installed on the box, several years ago.)
> Anyhow, i added an entry to /etc/grub.d just to see what would happen if i
> took the simple menu entry quite literally:
>     menuentry "simple-test" {
>         linux /boot/vmlinuz
>         initrd /boot/initrd.gz
>     }
> I ran 'sudo update-grub', and the entry was copied into /boot/grub/grub.cfg
> without modification.  And then i tried booting into it, just to see what
> grub would do.  And, it did what i think was the only thing it possibly
> could: it reported:
>     error: file `/boot/vmlinuz' not found.
>     error: you need to load the kernel first.
>     Press any key to continue...
> Now, Brian said that "the installer's initrd does not contain a loop
> module", so that would indicate that if i want to use
> debian-10.7.0-amd64-xfce-CD-1.iso, i'll need to get it on the disk
> (presumably by just unpacking it somewhere --- prior to booting, i can loop
> mount it and copy it to a 'real' directory), and then modifying
> /boot/vmlinuz and /boot/initrd.gz to be paths that grub understands.  Or,
> maybe the debootstrap method Bastien suggests would be good.

Both should be workable. 


Reply to: