[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Ipv6, but no Ipv4 after reboot

On 12/9/20, Andrei POPESCU <andreimpopescu@gmail.com> wrote:
> On Mi, 09 dec 20, 15:54:53, Dominique Dumont wrote:
>> Hi
>> I've run in a weird problem. After a reboot, only Ipv6 address is setup on
>> my
>> wired network card.
> Did something change or has it "always" been like this? What about other
> systems on the same network (if any).
>> The workaround is fairly simple: disconnect and reconnect with network
>> manager. Note that Ipv4 is brought up after suspend/resume
>> Still, this is cumbersome. I've found no obvious problems in the logs.

Maybe 2-year-old Bullseye with experimental wicd-curses here. Updates
are ALL current except for Linux kernel. It's on Developer hold. 1,000
other packages were, too, but they installed well so far. I just
didn't feel like fighting with the kernel if it failed.

Nope, I just installed all those files about 2 days ago. My version of
this issue began somewhere in the week or more before that. :)

In my case, I started having similar issues with wicd-curses. I
THOUGHT it was due to occasionally having to hit the hardware button
to shut down and then restart. I've experienced similar program
disfunction with other packages in the past so I just took it all as
being behavior that should be expected.

Then about two days ago, it happened during a nice, safe, normal reboot.

So far, it just takes ANOTHER reboot to become functional again.

My Firefox-ESR sessions are massive right now so it's a pain to open
to have to then immediately reboot, grin. I've finally figured out
that testing IPv4's presence before opening anything else works the
same as finding out after a large Firefox session has been brought up.

Testing is done with a simple disconnect then attempt to reconnect. It
will fail at that second if it's going to be a problem.

Tried purging and reinstalling ALL associated packages. That didn't help.

Tried altering the /etc/wicd/wired-settings.conf configuration file
since it was different between several instances of Bullseye installs.
Still no change.

Which brings up that it's initially functional *in my case*. It
remains functional until the first time it's disconnected during those
times that it's going to fail.

Yes, I've tried searching for a remedy. Nothing has clicked to date.

The rest of Andrei's email was over my comprehension ability just now.
Wouldn't even know where to start. Just wanted to chime in to say that
a second person is suddenly experiencing some form of this same thing.

PS The "ip a" command that came up here in last couple days was
perfectly timed. I'm able to see the IPv4 address appear and disappear
when I connect and disconnect via wicd-curses. I'm a-suming that
disappearing and reappearing in "ip a" output is IPv4's normal

Cindy :)
Cindy-Sue Causey
Talking Rock, Pickens County, Georgia, USA

* runs with birdseed *

Reply to: