[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt-get build-dep emacs-gtk: unmet dependencies

(I'm replying both public and private in response to your request for
such in another message. In turn, please respond on-list only -
preferably to the copy transmitted via the list, if possible; the way
you replied to deloptes seems to have produced the desired effect, at
least by what is publicly visible.)

On 2020-02-02 at 11:55, İ. Göktuğ Kayaalp wrote:

>> But libgnutls28-dev is in buster
> They all are, the problem is that build-dep:emacs requires packages
> which seem to require some downgrades.  These are not major downgrades,
> but minor version or debian package version:
> libtiff-dev : Depends: libtiff5 (= 4.0.10-4) but 4.1.0+git191117-2~deb10u1 is to be installed

What versions of libtiff-dev do you have available? In particular, what does

$ apt-cache policy libtiff-dev libtiff5


> libidn2-dev : Depends: libidn2-0 (= 2.0.5-1) but 2.0.5-1+deb10u1 is to be installed

Similarly here.

> So there's a minor version mismatch w/ libtiff5 and a debian patch
> version mismatch w/ libidn2-0.
> Is there any way I resolve this w/o making a mess?

Almost certainly. You just have to figure out what is making it decide
not to upgrade libtiff5 and libidn2.

The most common reasons in my experience are package holds / pins; I
think there are other reasons possible, but I can't think of them

Is there anything relevant in /etc/apt/preferences, or in files inside
/etc/apt/preferences.d/ ?

What does

$ apt-mark showhold


   The Wanderer

The reasonable man adapts himself to the world; the unreasonable one
persists in trying to adapt the world to himself. Therefore all
progress depends on the unreasonable man.         -- George Bernard Shaw

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: