[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Assorted arm-buster problems - network configuration

On Sunday 07 July 2019 02:58:46 andreimpopescu@gmail.com wrote:

> On Sb, 06 iul 19, 18:14:04, Gene Heskett wrote:
> > If you read the full thread, you will find where I found and fixed
> > that problem, by killing dhcpd5 with htop, and restarting
> > networking, and the problem was fixed, everything then worked
> > correctly,
> Did you ever find out why dhcpcd5 was even starting?
> As far as I know DHCP clients start only when called by network
> managing software (ifupdown, network-manager, etc.), or some custom
> networking scripts on your system. In this case it might show up again
> on the next reboot.
> BTW, it's still not clear to me whether this is about a clean buster
> install or some image based on buster.
Its the raspian image based on buster-rc2 AIUI.
And to get rid of the route poisoning that kills out of local networking 
by making it use a address for anything NOT in ones hosts 
file, I have purged avahi-daemon and dhcpdc5 and whatever dependencies 
they take out with them. And it takes a powerdown reboot to flush all 
the poisoning and make it work for out-of-the-local-net addresses.

I have finally achieved an overnight uptime with a working network.

pi@picnc:/var/log $ ip r
default via dev eth0 onlink dev eth0 proto kernel scope link src

pi@picnc:/etc/apt $ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group 
default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast 
state UP group default qlen 1000
    link/ether b8:27:eb:d3:47:2d brd ff:ff:ff:ff:ff:ff
    inet brd scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::ba27:ebff:fed3:472d/64 scope link
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group 
default qlen 1000
    link/ether b8:27:eb:86:12:78 brd ff:ff:ff:ff:ff:ff
and I can
pi@picnc:/etc/apt $ ping -c1 yahoo.com
PING yahoo.com ( 56(84) bytes of data.
64 bytes from media-router-fp1.prod1.media.vip.gq1.yahoo.com 
( icmp_seq=1 ttl=50 time=87.2 ms

--- yahoo.com ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 87.205/87.205/87.205/0.000 ms

Reinstalling avahi-daemon or dhcpcd5 will poison the routing, making the 
default route a address that only gets past the router at 
the dns phase, but the actual ping comes from the address 
block, and I am not sure it even gets to the cat6 plugged into the pi, 
but for sure is blocked by the managed switch or the router connected to 
the ARRIS cable modem upstream of the switch.

So it appears I finally have a working network.
But so far, no one has addressed the next problem. I do not have seating 
in any shape in front of the pi's own monitor and keyboard, and my 
standing time w/o excruciating back pain from two crushed disks in my 
back is maybe 15 minutes.  I would take a tall bar stool which there is 
no room for to make the position usable for an hour.

Therefore its imperative that ssh start on a reboot, which it does not do 
now, making me get out of this office chair, make my way to the other 
end of the house and out the back door, then into the garage where this 
pi is, stepping up on a $400 pile of mahogany for a furniture project 
and back off just to get to its workstation and restart ssh.

Then just now I find that synaptic won't run on wayland. So whats the 
substitute for synaptic? Something that will give me something graphical 
in front of apt so that I can see what sources are available.

the next step after making ssh work, is building and installing an 
rt-preempt version of this 4.19.50 kernel since its somewhat aware of 
the newer video drivers that 4.14.91-rt-v7 likely knows nothing about . 
I have tried RealtimePi 4 times now, but its newest kernel is 
4.14.91-rt-v7, which when booted doesn't find the wireless keyboard or 
mouse, nicely rendering it a quadraplegic. Meaning I've no clue if it 
will work even if it did find my keyboard and mouse. That particular 
keyboard nor mouse come in wired versions, and the square sided keys are 
a basic requirement around machinery that throws metal chips as it 
works, the slanted sides of all other keyboards keytop allow the metal 
chips to follow the key down, then wedge the key in the down position, 
an extremely dangerous situation thats cost me the loss of several hours 
work several times and several hundred $ in broken cutting tools.

> Kind regards,
> Andrei

Thank you Andrei 

Cheers, Gene Heskett
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
If we desire respect for the law, we must first make the law respectable.
 - Louis D. Brandeis
Genes Web page <http://geneslinuxbox.net:6309/gene>

Reply to: