[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: something wrong with audio

On Mon, Oct 8, 2018 at 7:08 PM <dotdeb@gmail.com> wrote:
Sorry for the subject not-so-specific but I hope this message can start a first iteration to better focus my problem.

The problem in short: no sound card available to pulsaudio, while ALSA seems to correctly detect HDA Intel PCH.
To make the problem more puzzling, in the same laptop with an ubuntu live (with kernel 4.15) audio works correctly.

Dear all, I have some upgrade (that partly solved the problem):

1. if I do not login as user into a desktop environment (in other words, if pulseaudio is not started) ALSA works correctly.
As I said in my first post, the strange stuff is that pulse does not see any card and fallback to a "dummy" sink, while alsa looks OK.

2. in a small partition I installed debian/stable and then dist-upgrade to sid to see how a fresh install behaves: everything is fine (both alsa and pulse).
This makes me think of some bad interaction with other packages OR configuration problems.
Actually, my sid have been alive for long time (years), and maybe some wrong (legacy) file under /etc can be there and cause problems.

This does not add very much to understanding the problem, but I think that working with unstable and keeping /etc for a long time, may generate some inconsistency that cannot be considered real bugs or misbehaviuor.

Conclusion: I consider the problem solved (or better, a "non-problem"). Because I spent too much time on it, I'll give it up andl use the newly installed and working debian/sid, transferring configuration step by step and verify that sound continue working.

Thank you to you all for the very kind help.


Reply to: