[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

More info - was [Re: Synaptic fails to fix broken packages]

On 10/04/2018 07:05 AM, Richard Owlett wrote:
On 10/03/2018 08:45 AM, Dan Purgert wrote:
Richard Owlett wrote:
I received an email with an attachment in .doc format.
I clicked to open with default program - LibreOffice Writer.
All I got was a brief display of the LibreOffice flash screen.
I tried to open from MATE's Application menu - failed likewise.

You sure that the *doc wasn't broken-by-design (i.e. one of the various
types of malware that tend to use *doc files, etc.)?

Not the problem on on two counts.
1. I had same symptoms when directly opening LibreOffice Writer from
    MATE's application menu.
2. I later found a flash drive to which I had installed Debian 8.
    The .doc file opened properly there.

Tried to do a complete removal with intention of doing a re-install.
Tried to do the re-install receiving a "fix broken packages" response.

Mind sending the package(s) that're causing the conflict?

Murphy decreed that the brokenness should evaporate ;/

A timeline:
1. Waited for a good night's sleep before following up your request.
2. I recently had a similar problem with Synaptic and was pointed to
    Synaptic's Help for fixing broken packages. I had not followed up
    as that machine had an apparent hardware/system failure. I'm on a
    different machine with a fresh install of Debian 9.
3. I attempted to view broken packages and got a list composed of
    packages I could not identify as ever having been installed.
    Did not notice any LibreOffice packages.
4. Did a search by package name for LibreOffice.
    Found many installed packages.
    Marked them for complete removal. Applied same.
    Now no evidence of broken packages.
5. Installed LibreOffice meta-package.
    It opened the doc file without problem.

As I've had similar problems twice I'll attempt to reproduce the problem. It will not be immediately as I have a higher priority project.

Is there a reproducible manner to break dependencies?

Thank you.

Just did a fresh install to another partition of the machine on which I observed the current problem.
Installation was from DVD 1 of Debian 9.1.0

Again LibreOffice Writer would not launch.
Attempted complete removal. This time the LibreOffice meta-package was identified as broke.
[I did _something_ ???]

Marked that package for installation.
All went well.
LibreOffice Writer launched properly from MATE application menu.

If/when I attempt again, what log files should I preserve.
I suspect that should include relevant log files from the clean install.

Reply to: