[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Firefox no longer able to play videos on Facebook


Until a few days ago, Firefox played videos on Facebook without issues, but now it cannot play the same videos anymore. It may coincide with me installing and uninstalling some Industrial Camera software (the only major change I remember doing in the meantime). It included make install, but I thought I got it cleaned up fine...

I've tried to reinstall Firefox, *codec*, *plugin*, *pepperflash* and some other packages, and tried to disable hw-accel in Firefox, without any change in luck.

I know it's hard to tell what went wrong, I'm also aware of the problematic deb-multimedia, but perhaps you guys can help me find out where to punch the system to get it to work again?


1) A few days ago Firefox played FB videos nicely.

2) Now Firefox console says (tried a few videos):
Error: The manifest specifies content that cannot be displayed on this browser/platform.  5-rDEXaxCbl.js:393:371 The video on this page can’t be played. Your system may not have the required video codecs for: video/mp4; codecs="avc1.4D401E", video/mp4; codecs="avc1.4D401E", video/mp4; codecs="avc1.4D401F", video/mp4; codecs="avc1.4D401F", audio/mp4; codecs="mp4a.40.5", video/mp4; codecs="avc1.42E01E mp4a.40.2", video/mp4; codecs="avc1.4D401E mp4a.40.2", video/mp4; codecs="avc1.4D401F mp4a.40.2", video/mp4; codecs="avc1.640032 mp4a.40.2", video/mp4; codecs="avc1.640033 mp4a.40.2"

3) Youtube plays fine both before and now.

4) I downloaded the FB Video with youtube-dl and played the video through Nautilus on VLC and Totem without problems.

5) Fully upgraded Debian Buster/Sid - Linux 4.18.0-1-amd64 #1 SMP Debian 4.18.6-1 (2018-09-06) x86_64 GNU/Linux.

deb http://ftp.dk.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.dk.debian.org/debian/ testing main contrib non-free
deb http://security.debian.org/debian-security testing/updates main contrib non-free deb-src http://security.debian.org/debian-security testing/updates main contrib non-free
deb http://www.deb-multimedia.org testing main non-free

/var/log/apt/history.log (around the time I installed/uninstalled the Cam software):
Start-Date: 2018-09-25  08:13:59
Install: libgirepository1.0-dev:amd64 (1.58.0-1), libzip4:amd64 (1.1.2-1.1+b1, automatic), libgstreamer1.0-dev:amd6 4 (1.14.3-1), libffi-dev:amd64 (3.2.1-8, automatic), libudev-dev:amd64 (239-9), libzip-dev:amd64 (1.1.2-1.1+b1), li
btinyxml-dev:amd64 (2.6.2-4), python3-setuptools:amd64 (40.2.0-1)
End-Date: 2018-09-25  08:14:03

Start-Date: 2018-09-25  08:16:11
Commandline: apt-get install gstreamer1.0-tools gstreamer1.0-x gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly libxml2 libpcap0.8 libaudit1 libnotify4 python3-pyqt5 python3-gi
Install: gstreamer1.0-tools:amd64 (1.14.3-1)
End-Date: 2018-09-25  08:16:12

Start-Date: 2018-09-25  08:22:02
Commandline: apt-get install git g++ cmake pkg-config libudev-dev libudev1 libtinyxml-dev libgstreamer1.0-dev libgs treamer-plugins-base1.0-dev libglib2.0-dev libgirepository1.0-dev libusb-1.0-0-dev libzip-dev uvcdynctrl python-set uptools libxml2-dev libpcap-dev libaudit-dev libnotify-dev autoconf intltool gtk-doc-tools python3-setuptools Install: libgstreamer-plugins-base1.0-dev:amd64 (1.14.3-dmo1), libpcap0.8-dev:amd64 (1.8.1-6, automatic), libwebcam 0:amd64 (0.2.4-1.1+b2, automatic), libegl1-mesa-dev:amd64 (18.1.7-1, automatic), docbook-to-man:amd64 (1:2.0.0-42, automatic), libnotify-dev:amd64 (0.7.7-3), highlight:amd64 (3.41-2, automatic), libpng-dev:amd64 (1.6.34-2, automat ic), libcap-ng-dev:amd64 (0.7.9-1, automatic), uvcdynctrl:amd64 (0.2.4-1.1+b2), docbook-xsl:amd64 (1.79.1+dfsg-2, a utomatic), liborc-0.4-dev:amd64 (1:0.4.28-2, automatic), highlight-common:amd64 (3.41-2, automatic), libwayland-bin :amd64 (1.16.0-1, automatic), libosp5:amd64 (1.5.2-13+b1, automatic), libwayland-dev:amd64 (1.16.0-1, automatic), o pensp:amd64 (1.5.2-13+b1, automatic), libxml2-dev:amd64 (2.9.4+dfsg1-7+b1), libgles2-mesa-dev:amd64 (18.1.7-1, auto matic), python-setuptools:amd64 (40.2.0-1), libgdk-pixbuf2.0-dev:amd64 (2.38.0+dfsg-6, automatic), gtk-doc-tools:am d64 (1.28-1), libaudit-dev:amd64 (1:2.8.4-2), python-funcsigs:amd64 (1.0.2-4, automatic), uvcdynctrl-data:amd64 (0. 2.4-1.1, automatic), liborc-0.4-dev-bin:amd64 (1:0.4.28-2, automatic), libpng-tools:amd64 (1.6.34-2, automatic), xs ltproc:amd64 (1.1.32-2, automatic), intltool:amd64 (0.51.0-5), docbook:amd64 (4.5-6, automatic), python-mock:amd64 (2.0.0-3, automatic), python-pbr:amd64 (4.2.0-4, automatic), libpcap-dev:amd64 (1.8.1-6)
End-Date: 2018-09-25  08:22:10

Start-Date: 2018-09-25  09:02:42
Purge: libgstreamer-plugins-base1.0-dev:amd64 (1.14.3-dmo1), libpcap0.8-dev:amd64 (1.8.1-6), libwebcam0:amd64 (0.2. 4-1.1+b2), libegl1-mesa-dev:amd64 (18.1.7-1), docbook-to-man:amd64 (1:2.0.0-42), libnotify-dev:amd64 (0.7.7-3), hig hlight:amd64 (3.41-2), libpng-dev:amd64 (1.6.34-2), libcap-ng-dev:amd64 (0.7.9-1), uvcdynctrl:amd64 (0.2.4-1.1+b2),  docbook-xsl:amd64 (1.79.1+dfsg-2), liborc-0.4-dev:amd64 (1:0.4.28-2), highlight-common:amd64 (3.41-2), libwayland- bin:amd64 (1.16.0-1), libosp5:amd64 (1.5.2-13+b1), libwayland-dev:amd64 (1.16.0-1), opensp:amd64 (1.5.2-13+b1), lib xml2-dev:amd64 (2.9.4+dfsg1-7+b1), libgles2-mesa-dev:amd64 (18.1.7-1), python-setuptools:amd64 (40.2.0-1), libgdk-p ixbuf2.0-dev:amd64 (2.38.0+dfsg-6), gtk-doc-tools:amd64 (1.28-1), libaudit-dev:amd64 (1:2.8.4-2), python-funcsigs:a md64 (1.0.2-4), uvcdynctrl-data:amd64 (0.2.4-1.1), liborc-0.4-dev-bin:amd64 (1:0.4.28-2), libpng-tools:amd64 (1.6.3 4-2), xsltproc:amd64 (1.1.32-2), intltool:amd64 (0.51.0-5), docbook:amd64 (4.5-6), python-mock:amd64 (2.0.0-3), pyt
hon-pbr:amd64 (4.2.0-4), libpcap-dev:amd64 (1.8.1-6)
End-Date: 2018-09-25  09:02:48

Start-Date: 2018-09-25  09:03:13
Purge: libgirepository1.0-dev:amd64 (1.58.0-1), libzip4:amd64 (1.1.2-1.1+b1), libgstreamer1.0-dev:amd64 (1.14.3-1),  gstreamer1.0-tools:amd64 (1.14.3-1), libffi-dev:amd64 (3.2.1-8), libudev-dev:amd64 (239-9), libzip-dev:amd64 (1.1. 2-1.1+b1), libtinyxml-dev:amd64 (2.6.2-4), python3-setuptools:amd64 (40.2.0-1)
End-Date: 2018-09-25  09:03:16


Reply to: