[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Previously Bootable: Stretch using Grub with GPT, LUKS, & BTRFS

On Tue, 11 Sep 2018 at 17:22, Igor Cicimov <icicimov@gmail.com> wrote:

On Tue, 11 Sep 2018 11:45 am Joel Brunetti <joelbrunetti@gmail.com> wrote:
Hey Team,

I'm having trouble booting a previously bootable system.
This system has been in use since very shortly before the Stretch release and has always been Stretch.
I'm using Grub to boot a fully encrypted system. Each drive is partitioned with GPT and encrypted using LUKS. The drives are then used together with BTRFS.

This system has worked with some minor boot problems (Which I thought were fixed by adding the bios_grub flag to my partition and the pmbr_boot flag to my disk) for at least a year.
Today I can not boot the system.  I suspect I've made it worse for trying to repair it so I will jump to where I am now.

When I boot I get on either device:
error: no such device: (UUID of my decrypted luks volume / btrfs pool)
error: unknown filesystem

Maybe check that the uuid hasn't changed somehow if mounting by uuid in /etc/fstab
The uuid in my fstab is correct. Unfortunately at boot it is not present because grub fails to open the luks devices.

I managed to get my system to work by sending my btrfs sub volume to another drive that was partitioned with MBR. There was no change to the filesystem.
I chrooted in and installed grub and with a few other minor changes to mount points my system is working again.

I have a poor understanding of GPT but I think GPT with grub and luks encryption is a little unstable.

Thanks for the help.

I've chrooted onto the system using a usb key.
I can open my encrypted drives and mount the btrfs filesystem.
I suspected a bad kernel or grub update so I:
update initramfs -u -k all
grub-install /dev/sda
grub-install /dev/sdb

This gives the above errors when I boot.

When I inspected /boot/grub/grub.cfg I noted it is missing "insmod cryptodisk" and other encryption related modules. This is despite /etc/default/grub containing "GRUB_ENABLE_CRYPTODISK=y".  I tried restoring /boot/grub/grub.cfg from a snapshot that does include those modules and then grub-install to both drives again but to no avail.

I'm really at a loss and could really use some help in restoring my system.


Reply to: