[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: painted into a corner

On Sunday 19 August 2018 17:15:43 Eike Lantzsch wrote:

> On Sunday, August 19, 2018 10:37:05 PM -04 john doe wrote:
> > On 8/19/2018 9:40 PM, Gene Heskett wrote:
> > > Greetings all;
> > >
> > > I just installed stretch to a fresh 2T HD. letting it
> > > autopartition and format for separate /, swap, /var and /home
> > > partitions. But I didn't let it overwrite the grub on the 1st
> > > drive it was/is  booting wheezy from.
> > >
> > > I figured I'd mount it to wheezy and copy over my personal stuff,
> > > like an email corpus well over 15GB reaching back to 2002.
> > >
> > > But I can't mount much of the drive, / is all that will actually
> > > mount, because the 2 versions of ext4 are incompatible, nearly all
> > > the mount and e2tools can't touch the installers ext4 file
> > > systems.
> > >
> > > For instance, its not mounted:
> > > gene@coyote:~$ e2fsck /dev/sdb8
> > > e2fsck 1.42.5 (29-Jul-2012)
> > > /dev/sdb8 has unsupported feature(s): metadata_csum
> > > e2fsck: Get a newer version of e2fsck!
> > >
> > > And of course whats installed to wheezy is the latest available
> > > wheezy version of e2fsck.
> > >
> > > Whats the recommended way to do these mounts so I can maintain as
> > > much continuity as possible?
> >
> > Maybe using apt-pinning.
> >
> > In other words, installing the version of Stretch/Jessie on wheezy.
> >
> > On the wheezy host, can't you backupt on an external hardware?
> In those cases I usually boot a recent live-CD (or USB-stick) like
> KNOPPIX and mount and copy from there.

I just rebooted to it, and I found a desktop interface that will wear out 
a set of batteries in my mouse weekly because it takes at least 8 to 10 
clicks and some scroll wheel work just to find a #@%# terminal, and it 
can't even add tabs to a different shell either! I didn't install 
anything special for a desktop, took the default because I intended to 
replace it with TDE asap, and going from 10 workspaces, 4 of which have 
multi-tabbed (up to 7 tabs each) konsoles running on them, with a 
pulldown text menu to run half the stuff I run on the other workspaces, 
to a single window, single tasking system thats worse than the last 
windows box I was asked to configure the networking on, was very 
disheartening.  So I added the trinity stuff to /etc/apt/sources.list.d 
using mc to copy that from the old disk, changing the wheezy in the deb 
line to stretch, and that did not get me the TDE desktop I've been using 
for years, but did get me some sort of a warning window that was taller 
than my screen, fussing that some repo I hadn't added, was duff. If 
debian is trying to kill itself, it was a heck of a good start, not even 
a windows user looking for something better would be impressed.

The only thing that Just Worked was the networking, it took everything 
for a static net and Just Worked on the reboot.  That was a rather 
pleasant surprise considering the only stretch based install on my 
rock64's that works at all was armbian.  None of the other arm|hf|64 
*bians will accept a gateway assignment except as as a route command 
after a login.

I'm burned out for today, my cataracts might have to be the next thing I 

Cheers, Gene Heskett
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <http://geneslinuxbox.net:6309/gene>

Reply to: