[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Audio - Dummy Output, except for root

On Mon, Jun 25, 2018 at 12:57 PM, Kent West <westk@acu.edu> wrote:

On Mon, Jun 25, 2018 at 10:57 AM, Brian <ad44@cityscape.co.uk> wrote:
On Mon 25 Jun 2018 at 09:58:29 -0500, Kent West wrote:

> So audio works for root, but not for my normal user (even after being added
> to the "audio" group).

In tinkering further, I find that when I run "alsamixer" from my normal user account, it shows my card and chip to be "PulseAudio", and if I press F6 to "Select sound card", I get an option of "- default" (where it's set), "0 HDA Intel PCH", and "1 HDA NVidia". If I run "alsamixer" from my root account, it shows my card and chip to be "HDA Intel PCH" and "Realtek ALC269VB".

I suspect I'm on the trail to fixing my problem, but I can't figure out how to change my default sound card. I can change it in alsamixer, but as soon as I get out of alsamixer and then go back in, it's back to "- default".

As I tinkered/thought further, I realize "- default" is probably where the alsamixer settings need to be. The problem is not that alsamixer is looking to the wrong card; it's that alsamixer's "- default" is looking to the wrong card.

I just discovered "pulsemixer" (aptitude install pulsemixer), and when I run it as a normal user, I see that there's a place to tell it what card to use. When I try to change cards, I find that the Intel PCH is not listed. Hmmm....

When I try to run "pulsemixer" as root, either from a TTY or from a second X session, I get a "can't connect to pulseaudio" type of error message. I haven't tried it yet as root as an only X session (as I've got real work going on as my normal user in that first X session, and don't want to interrupt it at the moment).

I don't understand the relationship between alsa and pulseaudio, but I *think* that in general terms, alsa is more of the fundamental driver base upon which pulseaudio then sits and relies. So it seems to me that root has access to the alsa driver for the Intel PCH, but my normal user no longer has that access.

Kent West                    <")))><
Westing Peacefully - http://kentwest.blogspot.com

Reply to: