[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Audio - Dummy Output, except for root

I recently dist-upgraded my Buster/Sid box, and lost:
 - networking temporarily (got it back, but not exactly sure how)
 -video (black screen; no obvious local terminal response, but could ssh in; it's an NVidia bug apparently, worked around with "slab_common.usercopy_fallback=y" added to kernel parameters at start-up)
 - audio as a normal user.

So I've fixed the first two issues, but still have no audio when I log into X as a normal user (or at least as my normal user; now that I think about it, I'll try as a different normal user as soon as I get this email sent off).

In both X11/Cinnamon and X11/Plasma Desktop, the audio button on the panel shows "Dummy Output" as the audio device when I log into X as my normal user. I added my user to the "audio" group and logged out/in and tried again; no change.

I then Ctrl-Alt-F1'd to TT1, logged in as root, "systemctl stop sddm", and "startx &" as root, and the DM was a simpler DM (maybe XFCE? maybe LXDE? it wasn't obvious, at least to me), and there was not volume control on any panel, so I just fired up Audacity and played a .m4v file, and audio worked successfully.

So audio works for root, but not for my normal user (even after being added to the "audio" group).

Any ideas/suggestions?


Kent West                    <")))><
Westing Peacefully - http://kentwest.blogspot.com

Reply to: