[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: installing 9.4 from the dvd's iso.

On Mon, 11 Jun 2018 18:57:27 -0400
Gene Heskett <gheskett@shentel.net> wrote:

> On Monday 11 June 2018 16:50:39 Patrick Bartek wrote:
> > On Mon, 11 Jun 2018 11:07:46 -0400
> >
> > Gene Heskett <gheskett@shentel.net> wrote:  
> > > Generally speaking, a big hey y'all to the developers.
> > >
> > > All of my squawks about the wheezy installer have been
> > > addressed.  
> >
> > Good to hear. However, I never had any problem with my custom
> > install of Wheezy 5 years ago.  Nor, for that matter, with Stretch.
> > Never bothered with Jessie.
> >  
> > > [snip]
> > >
> > > Just one thing seems to be missing: apt nor synaptic, will go out
> > > on the net and refresh the list of repo's in the sources.list. I
> > > have no clue if its because the network interface has been
> > > renamed from eth0 to enpsomething0, but it doesn't fetch the repo
> > > contents at all. Firefox was sent to look at a few sites, worked
> > > as expected so its not a network problem IMO.
> > >
> > > [snip]
> > >
> > > However an admittedly cursory read of all the files in /etc/apt,
> > > does not explain apt's reticence to download the new repo lists.
> > > So thats the next thing to fix.
> > >
> > > Can someone perhaps share a clue since I don't have one?  
> >
> > Show /etc/apt/sources.list as well as /etc/apt/sources.list.d/
> > files.  
> Had a heck of a time, seems the 2 lower trays in the hotswap cage are 
> still serviced with red sata cables, which are known to have only a 
> 4 or 5 year life, something in that red dye eats the copper into a 
> rusty looking powder. And thats the only 2 red cables left in this 
> decade old system. All the other original build red cables are gone.

Good to know.  All my sata cables are red. Came with the motherboard.
And this system like yours is 11 years old, although it's had
various upgrades (cpus, graphic cards, hard drives, power supply) since.
Fortunately, I've had no problems. However, next time I'm at the
computer store, I'm going to get new non-red cables. Can't hurt. Or,
maybe, I should build a NEW system.  Nah!  Against my frugal nature.
If it ain't broke, don't fix it. ;-)

> So I have that drive back to hanging out of the machine and mounted 
> on /media/sdcslash. On an orangish/tan cable. Black, blue, even green
> seem to be ok, but red may as well be tossed in the trash because you
> WILL eventually have to change it.

I only have two hard drives, both internal and no hotswaps.  In any
case, hard drives, etc. shouldn't be causing your failure to reach the
Debian repos.  You said your web browsing Internet connection worked
fine. Maybe, a firewall misconfigure or the repo you were trying to
reach was "down" or being updated itself at the time.  Had that happen.

> So here is that sources.list:
> (wordwrapoff)
> ==================
> # deb cdrom:[Debian GNU/Linux 9.4.0 _Stretch_ - Official amd64 DVD
> Binary-1 20180310-11:21]/ stretch contrib main # deb cdrom:[Debian
> GNU/Linux 9.4.0 _Stretch_ - Official amd64 DVD Binary-1
> 20180310-11:21]/ stretch contrib main 
> deb http://ftp.us.debian.org/debian/ stretch main non-free contrib 
> # deb-src http://ftp.us.debian.org/debian/ stretch main non-free
> contrib 
> deb http://security.debian.org/debian-security/ stretch/updates main
> contrib non-free # deb-src
> http://security.debian.org/debian-security/ stretch/updates main
> contrib non-free 
> # stretch-updates, previously known as 'volatile'
> deb http://ftp.us.debian.org/debian/ stretch-updates main contrib
> non-free # deb-src http://ftp.us.debian.org/debian/ stretch-updates
> main contrib non-free 
> # stretch-backports, previously on backports.debian.org
> deb http://ftp.us.debian.org/debian/ stretch-backports main contrib
> non-free # deb-src http://ftp.us.debian.org/debian/ stretch-backports
> main contrib non-free ===============

Looks okay.  Pretty much like mine at the moment.  I did a clean
install of Stretch (hard drive pre-partiioned in Wheezy) a couple
weeks ago, dual boot with my now 5 year old unsupported Wheezy install
as a backup. Both on the same hard drive.

FYI: Neither of my Debian installs are "stock' or UEFI.  MBR only. And
Stretch is chainloaded from Wheezy's grub which is on the MBR. Learned a
long time ago, not to mix-n-match distro grubs or lilos. I started with
a net-install disk base terminal only system, and built up from there.
However, I have no desktop.  Just a window manager (Openbox), menus,
and a single LXPanel. Network configured automatically during install.
Didn't have to do a thing. Refreshing.  PS: Converted to sysvinit as
init after base install, but kept all the systemd libraries as
dependencies.  No problems, so far.

> Now the sources.list.d contents: But its empty. Will have trinity r14 
> in it shortly as I'm quite used to TDE, its a Just Works desktop. That
> will bring in kmail so I can copy all my custom scripts over, and 
> actually start making stretch do my things.

Don't use desktops.  Installs too much crap I don't need or will
ever used. Resource hogs. All of them. Have heard good things about
Trinity as desktops go.

> /etc/apt/preferences.d is empty
> /etc/apt/trustedgpg seems to have the usual suspects for wheezy,
> jessie, and stretch.
> Anything else you need to see while I'm trying to corral some more
> sata cables that are NOT red?

No.  My /etc/apt/ is pretty much the same as yours at the moment,
except VirtualBox's repo (I downloaded the installer directly from
VB's site) is https as is Google's chrome's under preferences.list.d.
So, I needed to install apt-transport-https for them to work. I will
eventually convert all my repos to https and httpredir those that I
can.  Make sure everything works first before making a change, I say.

> Oh, is ifconfig and route on the first dvd? Its possible theres
> something wrong with the networking but I don't have the old
> standby's to show me. ip route looks sane but I'm the old hippy who
> has not yet seen that this "ip" stuff can actually replace ifconfig.

From my reading ifconfig, etc. have been abandoned, in favor of a new,
improved technique (they say).  Below are a few links to the new Debian
network configuring.  Hope it helps you solve your non-responsive
repo problem.

By the way, when you do an 'apt update' do you get any output?
Also, you are doing this as 'root', yes? Or sudo?  I don't have sudo
set up on my system.  Consider it a security risk.

I know you don't want to hear this, what with all the time you've
spent trying to make things work, but have you considered just
reinstalling everything with all the hardware set up as you want it to
see if it works?

Best of Luck.


Informational Links:





Reply to: