[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Latest buster upgrade gets stuck

On 2018-06-04 12:20 AM, Gary Dale wrote:
I'm running buster on an AMD64 system. I do an apt full-upgrade each night but tonight it's getting stuck. It seems to be building the initramfs image but having trouble with memtest86+. These are the last 6 lines that it displays then stops. The terminal window isn't frozen - it responds to <enter> for example by scrolling up.

Found initrd image: /boot/initrd.img-4.16.0-1-amd64
Found linux image: /boot/vmlinuz-4.15.0-3-amd64
Found initrd image: /boot/initrd.img-4.15.0-3-amd64
Found memtest86 image: /boot/memtest86.bin
Found memtest86+ image: /boot/memtest86+.bin
Found memtest86+ multiboot image: /boot/memtest86+_multiboot.bin

It originally got stuck on the apt full-upgrade. After waiting 15 or 20 minutes, I killed the process and ran dpkg --configure -a but got the same results.

Any ideas?

I thought the problem may be related to linux-headers-4.16.0-2-amd64 wasn't installed. This causes a problem setting up linux-image-4.16.0-2-amd64. However, after installing the headers, I'm still getting the same problem.

I also removed the various memtest86 packages since I don't really need them. Unfortunately the initramfs build still gets stuck.

Next I tried removing old kernel crud from /boot since apt seemed to be processing it when running the update-initramfs. Apt remove followed by a manual rm of the old files left me with just files related to the 4.16 kernels.

I even tried rebooting to see if that cleared up the problem. It didn't. I did notice however that I had the old grub options, which is expected since the update-grub command probably never executed.

Any ideas?

Reply to: