[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: USB Install Fails, Complains about CD-ROM

Thomas Schmitt wrote:

> Mike Kupfer wrote:
> > I used sha256sum instead of sha512sum, but I otherwise followed
> > the above instructions.  The checksum from the dd pipeline does not
> > match the checksum of the original .iso file.
> That's not good.
> Especially we do not have to show up at grub-devel as long as the test
> USB stick might have problems as storage device.
> >   dd if=/dev/sdb count=950976 bs=2048 | sha256sum
> > gives me the same result as
> >   sha256sum /dev/sdb1
> That's normal with Debian ISOs for "i386" and "amd64". The first partition
> marks the whole ISO.

That is true for the 9.4 netinst ISO, but there seems to be something
odd going on with the live image ISOs.

  alto$ sudo dd if=debian-live-9.4.0-amd64-xfce.iso of=/dev/sdb bs=32K
  [sudo] password for kupfer: 
  59554+0 records in
  59554+0 records out
  1951465472 bytes (2.0 GB, 1.8 GiB) copied, 455.702 s, 4.3 MB/s
  alto$ sudo isosize -x /dev/sdb
  sector count: 952848, sector size: 2048

But 952848 * 2048 = 1951432704, not 1951465472.

If I calculate the sector count from the size of the .iso file

  1951465472 / 2048 = 952864

and use that with dd piped to sha256sum, I do get the correct checksum:

    dd if=/dev/sdb count=952864 bs=2048 | sha256sum
    5d6f990bdd618902f9c0ce4b090d6547a77d89c3bab87136e6adf9a9378f4f39 -

That matches the value for the .iso, and it matches the value in

I saw this when testing multiple sticks, including the Verbatim stick
mentioned below, so I don't think this is a hardware glitch.  And I
observed something similar with the 9.2 Xfce live image ISO.

> > I just tried 9.4, using a different USB stick.  It fails in the same way

After running several tests, with 4 different sticks, 2 different ISOs
(the 9.4 netinst ISO and the 9.4 Xfce live image ISO), and 2 different
computers (the Latitude and my desktop), I believe the problem is, in
fact, the USB stick.  And not just the first one that I had problems
with.  It looks like there's something about that entire make/model
(MOSDART 8GB).  3 of the 4 sticks that I tested were MOSDART sticks, and
the 4th was a Verbatim stick.  I had problems with all 3 MOSDART sticks,
with both ISOs and both computers.  I had no problems with the Verbatim
stick with either ISO or computer, and that includes multiple tests
without any sort of "resting period" (with the power turned off).

Thomas, thanks again for all your help on this.  I'll have to be more
careful the next time I'm buying storage.


Reply to: