[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: USB Install Fails, Complains about CD-ROM

Kent West wrote:

> I have a Dell Latitude E7250 laptop. I'm trying to install Debian to it using a USB stick.

> The real problem is that after going through the first three or four
> screens, the install halts, complaining about not being able to read
> the CD-ROM.

Yes, I ran into the same problem with my E7250, using a netinst image
and a live image.

When trying to boot the live image I noticed these messages on the

  usb 1-2: device descriptor read/64, error -110
  usb 1-2: reset high-speed USB device number 2 using xhci_hcd

I tried booting from a different USB port; that worked once, but on a
subsequent attempt it failed with the same issue.

I did eventually get Debian installed, using a convoluted process that I
won't describe here because I suspect it's not relevant (see below).
I'm afraid that once I got Debian installed, I never went back to figure
out what was causing the earlier failures.

After reading your posting, I tried again to create a live USB stick.  I
used cp to copy the image to /dev/sdb, and I ran sync afterwards.  Same

I then tried using dd instead of cp, and I used a different USB port on
my desktop to write to the USB stick.  This time I could boot the live
image.  I checked kern.log, and it had

  usb 2-2: device descriptor read/64, error -110

but did not have the "reset" message.  (And I notice that this time
it's "usb 2-2" rather than "usb 1-2".)

I tried to boot off the USB stick a second time, and this time I got the
failure again.  So I suspect the problem has to do with peculiarities of
the E7250, rather than issues writing the USB stick.

I have a copy of kern.log from the first (successful) boot, and I have
the dmesg output from the second (failed) boot.  If anyone wants to look
at them, let me know.


Reply to: