[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: USB Install Fails, Complains about CD-ROM

On Fri, May 11, 2018 at 2:59 PM, Pascal Hambourg <pascal@plouf.fr.eu.org> wrote:
Le 11/05/2018 à 20:33, Kent West a écrit :

I learned that EFI boot drives need to have a GPT partition table. On a

This is not correct. The UEFI specification supports boot from a drive with an MSDOS partition table. Otherwise why would there be an "EFI system partition" type identifier (0xef) for MSDOS partition tables ? The Debian installer hybrid image has an MSDOS partition table. (It also has Apple and GPT partition tables, but they are bogus)

That's good to know. I guess my source material (https://www.happyassassin.net/2014/01/25/uefi-boot-how-does-that-actually-work-then/) is wrong. Or I misunderstood it.

lark, I ran "gparted --list", and discovered that the flash drive had a
"mac" partition table.


It is part of the image.

Okay. So I ran gparted, selected the drive, and created a new "GPT"
partition table, then repeated all my former steps, and bang! Success!

Copying the image again overwrote the GPT partition table and anything else you may have written to the stick. So it does not explain the success. You may have done something wrong the first time.

Possibly. With my first attempt, the "cp" happened very quickly. I didn't do a "sync", but I did use Cinnamon's system-tray thingie to eject the USB drive before unplugging it. With the second attempt, the "cp" took minutes (long enough I was beginning to think it had hung).

At any rate, I have a working system (except for wirelessly connecting to a secured network (unsecured works fine)), so I'm happy.


Kent West                    <")))><
Westing Peacefully - http://kentwest.blogspot.com

Reply to: