[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: USB Install Fails, Complains about CD-ROM

On Fri, May 11, 2018 at 1:33 PM, Kent West <westk@acu.edu> wrote:

On Fri, May 11, 2018 at 12:45 PM, songbird <songbird@anthive.com> wrote:
Kent West wrote:
> --000000000000b378b9056bf066d4
> Content-Type: text/plain; charset="UTF-8"
> I have a Dell Latitude E7250 laptop. I'm trying to install Debian to it
> using a USB stick.
> I've tried both of these .ISOs:
> debian-9.4.0-amd64-xfce-CD-1.iso
> debian-buster-DI-alpha2-amd64-xfce-CD-1.iso
> I used my desktop Debian box to download these via Firefox from
> https://www.debian.org/CD/http-ftp/
> I inserted a USB stick, and ran:
> # sudo cp debian-9.4.0-amd64-xfce-CD-1.iso /dev/sdc
> as per the instructions at https://www.debian.org/CD/faq/#write-usb
> I then ejected the USB stick from my desktop Debian box, and inserted it
> into the laptop, and then booted the laptop to the USB stick.
> The graphical install does not seem to recognize the trackpad (which is
> recognized in the laptop's EFI firmware settings, so I know it works), but
> that's a minor issue, as I can tinker with that later, and just use the
> keyboard to install for now.
> The real problem is that after going through the first three or four
> screens, the install halts, complaining about not being able to read the
> Googling the issue suggested a couple of possible fixes, but I've had no
> success yet.
> Any help?

  try the netinst images instead and when you do the copy
make sure it is sync'd before removing USB device.  on my
system the cp returns very quickly but the sync may take
some time before everything is written to the USB stick.


While chasing down a completely different issue unrelated to this install, I learned that EFI boot drives need to have a GPT partition table. On a lark, I ran "gparted --list", and discovered that the flash drive had a "mac" partition table.


Okay. So I ran gparted, selected the drive, and created a new "GPT" partition table, then repeated all my former steps, and bang! Success! It's currently pulling down gobs of stuff (I elected to install Cinnamon and KDE and Gnome - always fun to overload a drive unnecessarily ;-) ).


Just for kicks, after getting a working system, I plugged the USB stick back in, and again ran "parted --list", and the stick again shows up as a "mac" partition table.


But it worked to install, so I'm not gonna bother thinking about it any more.

Well, the trackpad still doesn't work in the installer, but I have half a suspicion that once the system boots, the trackpad will work. We'll see in a few.

Yep, when I booted into the installed system, the trackpad works just fine.

Now to tackle that nasty broadcom wireless.... :-(

Kent West                    <")))><
Westing Peacefully - http://kentwest.blogspot.com

Reply to: