[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[solved]Re: anacron mysteriously not working

On Sun, 6 May 2018 10:14:54 +0100
Jonathan de Boyne Pollard <J.deBoynePollard-newsgroups@NTLWorld.COM>

> Michael Lange:
> > [...] I discovered that the syslog had become rather huge, so 
> > apparently logrotate had not been performed for months.
> >
> See the thread started by John Cunningham on this very mailing list on 
> this topic 6 days before you did.

I had read this before, but the problem reported there seemed to be quite
different from mine.

As I said, anacron refused to do anything when started manually. I tried
to start anacron -fnd via strace, which showed that anacron loaded the
locale configuration files and then stopped for no apparent reason
without really doing anything. I suspected that it didn't like something
about my locale settings or maybe some environment variable. Hard to tell
though if you don't get any error message.
Anyway, I found out about the systemd-cron package, purged cron and
anacron and installed systemd-cron, which seems to do its job properly.



.-.. .. ...- .   .-.. --- -. --.   .- -. -..   .--. .-. --- ... .--. . .-.

It would seem that evil retreats when forcibly confronted.
		-- Yarnek of Excalbia, "The Savage Curtain", stardate

Reply to: